aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-03-04 11:12:44 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-03-04 11:12:44 +0000
commitec3890b76c452f870faaef3b4b00e731b94b9e52 (patch)
tree24feae61e6354d66589eef632ad9b2419cfdf2a7 /8.4.0/gentoo/10_all_nopie-all-flags.patch
parent8.3.0: abandon patchset in favour of 8.4.0 release (diff)
downloadgcc-patches-ec3890b76c452f870faaef3b4b00e731b94b9e52.tar.gz
gcc-patches-ec3890b76c452f870faaef3b4b00e731b94b9e52.tar.bz2
gcc-patches-ec3890b76c452f870faaef3b4b00e731b94b9e52.zip
8.4.0: cut patchset 1, a copy of 8.3.0 patchset without upstreamed patches
The only change from 8.3.0 is removal of 3 upstreamed patches: - 16_all_sh_textrel-on-libitm.patch # upstreamed - 27_all_flto-make-all.patch # upstreamed - 28_all_i386_retpoline-and-jumptable.patch # upstreamed Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to '8.4.0/gentoo/10_all_nopie-all-flags.patch')
-rw-r--r--8.4.0/gentoo/10_all_nopie-all-flags.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/8.4.0/gentoo/10_all_nopie-all-flags.patch b/8.4.0/gentoo/10_all_nopie-all-flags.patch
new file mode 100644
index 0000000..48536e6
--- /dev/null
+++ b/8.4.0/gentoo/10_all_nopie-all-flags.patch
@@ -0,0 +1,18 @@
+We need to pass NO_PIE_CFLAGS to ALL_* so gcc don't fail when
+we compile it with older gcc and pie.
+
+--- a/gcc/Makefile.in 2015-06-25 19:18:12.000000000 +0200
++++ b/gcc/Makefile.in 2016-04-22 00:12:54.029178860 +0200
+@@ -991,10 +991,10 @@ ALL_CXXFLAGS = $(T_CFLAGS) $(CFLAGS-$@)
+ ALL_CPPFLAGS = $(INCLUDES) $(CPPFLAGS)
+
+ # This is the variable to use when using $(COMPILER).
+-ALL_COMPILERFLAGS = $(ALL_CXXFLAGS)
++ALL_COMPILERFLAGS = $(NO_PIE_CFLAGS) $(ALL_CXXFLAGS)
+
+ # This is the variable to use when using $(LINKER).
+-ALL_LINKERFLAGS = $(ALL_CXXFLAGS)
++ALL_LINKERFLAGS = $(NO_PIE_CFLAGS) $(ALL_CXXFLAGS)
+
+ # Build and host support libraries.
+