summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-12-06 17:35:19 -0500
committerMichael Orlitzky <mjo@gentoo.org>2015-12-06 17:35:19 -0500
commit61cda41fb7750a8e0afa344af30a235fe68ef4f9 (patch)
tree222f54e764b3de7161366fa9e1c6bdffa4bfe9c3
parentApply Brian Evans's patch to support php-7.x with apache2. (diff)
downloadeselect-php-61cda41fb7750a8e0afa344af30a235fe68ef4f9.tar.gz
eselect-php-61cda41fb7750a8e0afa344af30a235fe68ef4f9.tar.bz2
eselect-php-61cda41fb7750a8e0afa344af30a235fe68ef4f9.zip
Create trivial autotools "build system."
-rw-r--r--Makefile.am2
-rwxr-xr-xautogen.sh2
-rw-r--r--configure.ac7
3 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..330f491
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,2 @@
+eselectdir = $(datadir)/eselect/modules
+nodist_eselect_DATA = src/php.eselect
diff --git a/autogen.sh b/autogen.sh
new file mode 100755
index 0000000..89dcaff
--- /dev/null
+++ b/autogen.sh
@@ -0,0 +1,2 @@
+#!/bin/sh -x
+exec autoreconf -fi
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..72c9e6f
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,7 @@
+AC_INIT([eselect-php], [0.8.0])
+AM_INIT_AUTOMAKE([-Wall foreign no-dist-gzip dist-xz])
+
+# List of output files.
+AC_CONFIG_FILES([Makefile src/php.eselect])
+
+AC_OUTPUT