summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/hub/hub-9999.ebuild')
-rw-r--r--dev-vcs/hub/hub-9999.ebuild34
1 files changed, 13 insertions, 21 deletions
diff --git a/dev-vcs/hub/hub-9999.ebuild b/dev-vcs/hub/hub-9999.ebuild
index 0e6a05c..7d28df1 100644
--- a/dev-vcs/hub/hub-9999.ebuild
+++ b/dev-vcs/hub/hub-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=6
inherit bash-completion-r1 git-r3 readme.gentoo-r1
-DESCRIPTION="command-line wrapper for git that makes you better at GitHub"
+DESCRIPTION="Command-line wrapper for git that makes you better at GitHub"
HOMEPAGE="http://defunkt.io/hub/"
SRC_URI=""
EGIT_REPO_URI="https://github.com/github/hub.git"
@@ -14,43 +14,35 @@ EGIT_REPO_URI="https://github.com/github/hub.git"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE="test"
+IUSE=""
-RDEPEND="dev-vcs/git"
-DEPEND="
- dev-lang/go
- test? (
- app-misc/tmux
- dev-util/cucumber
- dev-ruby/bundler
- )"
+DEPEND=">=dev-lang/go-1.5.1:="
+RDEPEND=">=dev-vcs/git-1.7.3"
DOC_CONTENTS="You may want to add 'alias git=hub' to your .{csh,bash}rc"
src_compile() {
- bash ./script/build || die
+ ./script/build || die
}
-src_test() {
- bash ./script/test || die
-}
+#src_test() {
+# ./script/test || die
+#}
src_install() {
- dobin ${PN}
-
readme.gentoo_create_doc
- doman man/${PN}.1
+ dobin hub
- insinto /usr/share/${PN}/
- doins -r git-hooks
+ doman man/${PN}.1
+ dodoc README.md
# Broken with autoloader
# https://github.com/github/hub/issues/592
- #newbashcomp etc/hub.bash_completion.sh ${PN}
+ #newbashcomp etc/${PN}.bash_completion.sh ${PN}
insinto /usr/share/zsh/site-functions
- newins etc/hub.zsh_completion ${PN}
+ newins etc/hub.zsh_completion _${PN}
}
pkg_postinst() {