diff options
author | Christian Heimes <christian@python.org> | 2016-09-18 14:34:13 +0200 |
---|---|---|
committer | Christian Heimes <christian@python.org> | 2016-09-18 14:34:13 +0200 |
commit | 85c98bf9682a46f7b15e9c79c68d38af8a9109b0 (patch) | |
tree | 8592062b314091dedff37a27c5218dbd41d51f4f /setup.py | |
parent | Null merge from 3.5 (diff) | |
parent | Issue #26661: setup.py now detects system libffi with multiarch wrapper. (diff) | |
download | cpython-85c98bf9682a46f7b15e9c79c68d38af8a9109b0.tar.gz cpython-85c98bf9682a46f7b15e9c79c68d38af8a9109b0.tar.bz2 cpython-85c98bf9682a46f7b15e9c79c68d38af8a9109b0.zip |
Issue #26661: setup.py now detects system libffi with multiarch wrapper.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 16 |
1 files changed, 9 insertions, 7 deletions
@@ -2025,14 +2025,16 @@ class PyBuildExt(build_ext): ffi_inc = find_file('ffi.h', [], inc_dirs) if ffi_inc is not None: ffi_h = ffi_inc[0] + '/ffi.h' - with open(ffi_h) as fp: - while 1: - line = fp.readline() - if not line: - ffi_inc = None - break - if line.startswith('#define LIBFFI_H'): + with open(ffi_h) as f: + for line in f: + line = line.strip() + if line.startswith(('#define LIBFFI_H', + '#define ffi_wrapper_h')): break + else: + ffi_inc = None + print('Header file {} does not define LIBFFI_H or ' + 'ffi_wrapper_h'.format(ffi_h)) ffi_lib = None if ffi_inc is not None: for lib_name in ('ffi', 'ffi_pic'): |