aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Krah <skrah@bytereef.org>2017-02-04 14:59:11 +0100
committerStefan Krah <skrah@bytereef.org>2017-02-04 14:59:11 +0100
commit26581785f3625e05d888f120dac9087002d5602e (patch)
tree7d8f2629e4513ee116595320adcff3a665cda22b /setup.py
parentReduce load factor (from 66% to 60%) to improve effectiveness of linear probing. (diff)
parentIssue29439: _decimal on Android requires linking with libm. (diff)
downloadcpython-26581785f3625e05d888f120dac9087002d5602e.tar.gz
cpython-26581785f3625e05d888f120dac9087002d5602e.tar.bz2
cpython-26581785f3625e05d888f120dac9087002d5602e.zip
Merge 3.6.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 2cbe9a5805f..3b3d0974542 100644
--- a/setup.py
+++ b/setup.py
@@ -2015,7 +2015,7 @@ class PyBuildExt(build_ext):
'Modules',
'_decimal',
'libmpdec'))]
- libraries = []
+ libraries = self.detect_math_libs()
sources = [
'_decimal/_decimal.c',
'_decimal/libmpdec/basearith.c',