aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2004-09-26 17:26:55 +0000
committerMartin v. Löwis <martin@v.loewis.de>2004-09-26 17:26:55 +0000
commit4d9559a47e2c39aabf1ea9ae30be892841f3e73b (patch)
tree360723197f1621d4cdeb28c13986fb4f1c5b0229 /Makefile.pre.in
parentUpdated doctest doc news. (diff)
downloadcpython-4d9559a47e2c39aabf1ea9ae30be892841f3e73b.tar.gz
cpython-4d9559a47e2c39aabf1ea9ae30be892841f3e73b.tar.bz2
cpython-4d9559a47e2c39aabf1ea9ae30be892841f3e73b.zip
Replace -soname with -h for Solaris compatibility. Fixes #1034496.
Backported to 2.3.
Diffstat (limited to 'Makefile.pre.in')
-rw-r--r--Makefile.pre.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.pre.in b/Makefile.pre.in
index e7220b6c7c4..d1ea4e27004 100644
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -351,7 +351,7 @@ $(LIBRARY): $(LIBRARY_OBJS)
libpython$(VERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
- $(LDSHARED) -Wl,-soname=$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(SHLIBS) $(LIBC) $(LIBM); \
+ $(LDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(SHLIBS) $(LIBC) $(LIBM); \
$(LN) -f $(INSTSONAME) $@; \
else\
$(LDSHARED) -o $@ $(LIBRARY_OBJS) $(SHLIBS) $(LIBC) $(LIBM); \