aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2006-04-17 19:25:49 +0000
committerMartin v. Löwis <martin@v.loewis.de>2006-04-17 19:25:49 +0000
commit4be4e657e05036d6e617b4ad636b4b2543aac355 (patch)
treec7bc094c1756bc3573ac6ef3d8000de56fa2a734 /Makefile.pre.in
parentReindent. (diff)
downloadcpython-4be4e657e05036d6e617b4ad636b4b2543aac355.tar.gz
cpython-4be4e657e05036d6e617b4ad636b4b2543aac355.tar.bz2
cpython-4be4e657e05036d6e617b4ad636b4b2543aac355.zip
Add reindent target.
Diffstat (limited to 'Makefile.pre.in')
-rw-r--r--Makefile.pre.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.pre.in b/Makefile.pre.in
index 91d4849c07d..b1cf8c23757 100644
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -956,6 +956,10 @@ config.status: $(srcdir)/configure
.c.o:
$(CC) -c $(PY_CFLAGS) -o $@ $<
+# Run reindent on the library
+reindent:
+ ./python$(EXEEXT) $(srcdir)/Tools/scripts/reindent.py -r $(srcdir)/Lib
+
# Rerun configure with the same options as it was run last time,
# provided the config.status script exists
recheck: