aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2006-04-11 07:15:30 +0000
committerMartin v. Löwis <martin@v.loewis.de>2006-04-11 07:15:30 +0000
commit44fe0e4b8d510dfc82903d2a45579e10a1bcb005 (patch)
treee060195a4f6898f4419821afd4e9edfaf9e35f79
parentClear errno before calling opendir() and readdir(). (diff)
downloadcpython-44fe0e4b8d510dfc82903d2a45579e10a1bcb005.tar.gz
cpython-44fe0e4b8d510dfc82903d2a45579e10a1bcb005.tar.bz2
cpython-44fe0e4b8d510dfc82903d2a45579e10a1bcb005.zip
Correct test whether wchar_t is unsigned. Fixed crash
in #1454485.
-rwxr-xr-xconfigure5
-rw-r--r--configure.in3
2 files changed, 5 insertions, 3 deletions
diff --git a/configure b/configure
index f8183f2c6c4..6f2d0952c2d 100755
--- a/configure
+++ b/configure
@@ -1,5 +1,5 @@
#! /bin/sh
-# From configure.in Revision: 43615 .
+# From configure.in Revision: 43748 .
# Guess values for system-dependent variables and create Makefiles.
# Generated by GNU Autoconf 2.59 for python 2.5.
#
@@ -20019,7 +20019,8 @@ cat >>conftest.$ac_ext <<_ACEOF
#include <wchar.h>
int main()
{
- exit((((wchar_t) -1) < ((wchar_t) 0)) ? 1 : 0);
+ /* Success: exit code 0 */
+ exit((((wchar_t) -1) < ((wchar_t) 0)) ? 0 : 1);
}
_ACEOF
diff --git a/configure.in b/configure.in
index 612d2fa91b3..a043ce59d18 100644
--- a/configure.in
+++ b/configure.in
@@ -2792,7 +2792,8 @@ then
#include <wchar.h>
int main()
{
- exit((((wchar_t) -1) < ((wchar_t) 0)) ? 1 : 0);
+ /* Success: exit code 0 */
+ exit((((wchar_t) -1) < ((wchar_t) 0)) ? 0 : 1);
}
],
ac_cv_wchar_t_signed=yes,