aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Svetlov <andrew.svetlov@gmail.com>2017-12-14 16:19:51 +0200
committerGitHub <noreply@github.com>2017-12-14 16:19:51 +0200
commit28453feaa8d88bbcbf6d834b1d5ca396d17265f2 (patch)
treee228f9ddb6795965d302e6d16c2e4bfb0b074d17
parentbpo-32302: Fix distutils bdist_wininst for CRT v142 (GH-4851) (#4861) (diff)
downloadcpython-28453feaa8d88bbcbf6d834b1d5ca396d17265f2.tar.gz
cpython-28453feaa8d88bbcbf6d834b1d5ca396d17265f2.tar.bz2
cpython-28453feaa8d88bbcbf6d834b1d5ca396d17265f2.zip
[3.6] bpo-32297: Fix misspellings in Python source code comments (GH-4803) (#4864)
* [3.6] bpo-32297: Few misspellings found in Python source code comments. (GH-4803) * Fix multiple typos in code comments * Add spacing in comments (test_logging.py, test_math.py) * Fix spaces at the beginning of comments in test_logging.py. (cherry picked from commit 53f7a7c2814fbfd8a29200926601a32fa48bacb3)
-rw-r--r--Doc/includes/email-read-alternative.py2
-rw-r--r--Lib/ctypes/test/test_pep3118.py2
-rw-r--r--Lib/ctypes/test/test_structures.py2
-rw-r--r--Lib/email/quoprimime.py2
-rw-r--r--Lib/http/client.py2
-rw-r--r--Lib/os.py2
-rwxr-xr-xLib/tarfile.py2
-rw-r--r--Lib/test/_test_multiprocessing.py2
-rw-r--r--Lib/test/test_baseexception.py2
-rw-r--r--Lib/test/test_class.py1
-rw-r--r--Lib/test/test_collections.py6
-rw-r--r--Lib/test/test_functools.py2
-rw-r--r--Lib/test/test_generators.py2
-rw-r--r--Lib/test/test_importlib/builtin/test_finder.py2
-rw-r--r--Lib/test/test_inspect.py2
-rw-r--r--Lib/test/test_io.py4
-rw-r--r--Lib/test/test_largefile.py4
-rw-r--r--Lib/test/test_logging.py50
-rw-r--r--Lib/test/test_math.py2
-rw-r--r--Lib/test/test_parser.py2
-rw-r--r--Lib/test/test_random.py2
-rw-r--r--Lib/test/test_site.py2
-rw-r--r--Lib/test/test_socket.py4
-rw-r--r--Lib/test/test_ssl.py2
-rw-r--r--Lib/test/test_sys_settrace.py2
-rw-r--r--Lib/test/test_xml_etree.py2
-rw-r--r--Lib/test/test_zipapp.py8
-rw-r--r--Lib/tkinter/test/test_ttk/test_functions.py4
-rw-r--r--Lib/tkinter/ttk.py2
-rw-r--r--Lib/turtledemo/__main__.py2
-rw-r--r--Lib/unittest/test/testmock/testmagicmethods.py2
-rw-r--r--Lib/xml/etree/ElementTree.py2
-rw-r--r--Lib/xmlrpc/client.py4
-rwxr-xr-xMac/BuildScript/build-installer.py2
-rw-r--r--Modules/faulthandler.c2
-rw-r--r--setup.py2
36 files changed, 70 insertions, 69 deletions
diff --git a/Doc/includes/email-read-alternative.py b/Doc/includes/email-read-alternative.py
index 3f5ab24c0fb..5ea84e62584 100644
--- a/Doc/includes/email-read-alternative.py
+++ b/Doc/includes/email-read-alternative.py
@@ -21,7 +21,7 @@ print('To:', msg['to'])
print('From:', msg['from'])
print('Subject:', msg['subject'])
-# If we want to print a priview of the message content, we can extract whatever
+# If we want to print a preview of the message content, we can extract whatever
# the least formatted payload is and print the first three lines. Of course,
# if the message has no plain text part printing the first three lines of html
# is probably useless, but this is just a conceptual example.
diff --git a/Lib/ctypes/test/test_pep3118.py b/Lib/ctypes/test/test_pep3118.py
index f3c0e23e53e..81e8ca7638f 100644
--- a/Lib/ctypes/test/test_pep3118.py
+++ b/Lib/ctypes/test/test_pep3118.py
@@ -188,7 +188,7 @@ native_types = [
(PackedPoint, "B", (), PackedPoint),
(Point2, "T{<l:x:<l:y:}".replace('l', s_long), (), Point2),
(EmptyStruct, "T{}", (), EmptyStruct),
- # the pep does't support unions
+ # the pep doesn't support unions
(aUnion, "B", (), aUnion),
# structure with sub-arrays
(StructWithArrays, "T{(2,3)<l:x:(4)T{<l:x:<l:y:}:y:}".replace('l', s_long), (), StructWithArrays),
diff --git a/Lib/ctypes/test/test_structures.py b/Lib/ctypes/test/test_structures.py
index 2e778fb1b43..4ad5915ba27 100644
--- a/Lib/ctypes/test/test_structures.py
+++ b/Lib/ctypes/test/test_structures.py
@@ -129,7 +129,7 @@ class StructureTestCase(unittest.TestCase):
self.assertEqual(sizeof(XX), 0)
def test_fields(self):
- # test the offset and size attributes of Structure/Unoin fields.
+ # test the offset and size attributes of Structure/Union fields.
class X(Structure):
_fields_ = [("x", c_int),
("y", c_char)]
diff --git a/Lib/email/quoprimime.py b/Lib/email/quoprimime.py
index c543eb59ae7..94534f7ee1e 100644
--- a/Lib/email/quoprimime.py
+++ b/Lib/email/quoprimime.py
@@ -173,7 +173,7 @@ def body_encode(body, maxlinelen=76, eol=NL):
if not body:
return body
- # quote speacial characters
+ # quote special characters
body = body.translate(_QUOPRI_BODY_ENCODE_MAP)
soft_break = '=' + eol
diff --git a/Lib/http/client.py b/Lib/http/client.py
index a8e59b95616..8a82c57eb5d 100644
--- a/Lib/http/client.py
+++ b/Lib/http/client.py
@@ -540,7 +540,7 @@ class HTTPResponse(io.BufferedIOBase):
chunk_left = self.chunk_left
if not chunk_left: # Can be 0 or None
if chunk_left is not None:
- # We are at the end of chunk. dicard chunk end
+ # We are at the end of chunk, discard chunk end
self._safe_read(2) # toss the CRLF at the end of the chunk
try:
chunk_left = self._read_next_chunk_size()
diff --git a/Lib/os.py b/Lib/os.py
index 9fa8acb4b13..c7e24a384af 100644
--- a/Lib/os.py
+++ b/Lib/os.py
@@ -882,7 +882,7 @@ If mode == P_WAIT return the process's exit code if it exits normally;
otherwise return -SIG, where SIG is the signal that killed it. """
return _spawnvef(mode, file, args, env, execve)
- # Note: spawnvp[e] is't currently supported on Windows
+ # Note: spawnvp[e] isn't currently supported on Windows
def spawnvp(mode, file, args):
"""spawnvp(mode, file, args) -> integer
diff --git a/Lib/tarfile.py b/Lib/tarfile.py
index 5d4c86ce366..631b69dcba4 100755
--- a/Lib/tarfile.py
+++ b/Lib/tarfile.py
@@ -1056,7 +1056,7 @@ class TarInfo(object):
# The old GNU sparse format occupies some of the unused
# space in the buffer for up to 4 sparse structures.
- # Save the them for later processing in _proc_sparse().
+ # Save them for later processing in _proc_sparse().
if obj.type == GNUTYPE_SPARSE:
pos = 386
structs = []
diff --git a/Lib/test/_test_multiprocessing.py b/Lib/test/_test_multiprocessing.py
index f01c0041d65..774e797f02e 100644
--- a/Lib/test/_test_multiprocessing.py
+++ b/Lib/test/_test_multiprocessing.py
@@ -3896,7 +3896,7 @@ class TestNoForkBomb(unittest.TestCase):
#
class TestForkAwareThreadLock(unittest.TestCase):
- # We recurisvely start processes. Issue #17555 meant that the
+ # We recursively start processes. Issue #17555 meant that the
# after fork registry would get duplicate entries for the same
# lock. The size of the registry at generation n was ~2**n.
diff --git a/Lib/test/test_baseexception.py b/Lib/test/test_baseexception.py
index 27d514fe2ee..e7ce0b43456 100644
--- a/Lib/test/test_baseexception.py
+++ b/Lib/test/test_baseexception.py
@@ -163,7 +163,7 @@ class UsageTests(unittest.TestCase):
self.raise_fails("spam")
def test_catch_non_BaseException(self):
- # Tryinng to catch an object that does not inherit from BaseException
+ # Trying to catch an object that does not inherit from BaseException
# is not allowed.
class NonBaseException(object):
pass
diff --git a/Lib/test/test_class.py b/Lib/test/test_class.py
index ecc01f27795..507c723e718 100644
--- a/Lib/test/test_class.py
+++ b/Lib/test/test_class.py
@@ -595,5 +595,6 @@ class ClassTests(unittest.TestCase):
with self.assertRaises(TypeError):
type.__setattr__(A, b'x', None)
+
if __name__ == '__main__':
unittest.main()
diff --git a/Lib/test/test_collections.py b/Lib/test/test_collections.py
index 47f756213dd..cbb08dbdd75 100644
--- a/Lib/test/test_collections.py
+++ b/Lib/test/test_collections.py
@@ -550,7 +550,7 @@ class TestOneTrickPonyABCs(ABCTestCase):
c = new_coro()
self.assertIsInstance(c, Awaitable)
- c.close() # awoid RuntimeWarning that coro() was not awaited
+ c.close() # avoid RuntimeWarning that coro() was not awaited
class CoroLike: pass
Coroutine.register(CoroLike)
@@ -600,7 +600,7 @@ class TestOneTrickPonyABCs(ABCTestCase):
c = new_coro()
self.assertIsInstance(c, Coroutine)
- c.close() # awoid RuntimeWarning that coro() was not awaited
+ c.close() # avoid RuntimeWarning that coro() was not awaited
class CoroLike:
def send(self, value):
@@ -1607,7 +1607,7 @@ class TestCollectionABCs(ABCTestCase):
'__len__', '__getitem__', '__setitem__', '__delitem__', 'insert')
def test_MutableSequence_mixins(self):
- # Test the mixins of MutableSequence by creating a miminal concrete
+ # Test the mixins of MutableSequence by creating a minimal concrete
# class inherited from it.
class MutableSequenceSubclass(MutableSequence):
def __init__(self):
diff --git a/Lib/test/test_functools.py b/Lib/test/test_functools.py
index cd4664cec08..145440027c9 100644
--- a/Lib/test/test_functools.py
+++ b/Lib/test/test_functools.py
@@ -420,7 +420,7 @@ class TestPartialC(TestPartial, unittest.TestCase):
p.keywords[self] = ['sth2']
return 'astr'
- # Raplacing the value during key formatting should keep the original
+ # Replacing the value during key formatting should keep the original
# value alive (at least long enough).
p.keywords[MutatesYourDict()] = ['sth']
r = repr(p)
diff --git a/Lib/test/test_generators.py b/Lib/test/test_generators.py
index 7107bd99932..b8d5bbe3b05 100644
--- a/Lib/test/test_generators.py
+++ b/Lib/test/test_generators.py
@@ -1459,7 +1459,7 @@ class Knights:
# If we create a square with one exit, we must visit it next;
# else somebody else will have to visit it, and since there's
# only one adjacent, there won't be a way to leave it again.
- # Finelly, if we create more than one free square with a
+ # Finally, if we create more than one free square with a
# single exit, we can only move to one of them next, leaving
# the other one a dead end.
ne0 = ne1 = 0
diff --git a/Lib/test/test_importlib/builtin/test_finder.py b/Lib/test/test_importlib/builtin/test_finder.py
index a2e6e1edc36..084f3de6b65 100644
--- a/Lib/test/test_importlib/builtin/test_finder.py
+++ b/Lib/test/test_importlib/builtin/test_finder.py
@@ -22,7 +22,7 @@ class FindSpecTests(abc.FinderTests):
# Built-in modules cannot be a package.
test_package = None
- # Built-in modules cannobt be in a package.
+ # Built-in modules cannot be in a package.
test_module_in_package = None
# Built-in modules cannot be a package.
diff --git a/Lib/test/test_inspect.py b/Lib/test/test_inspect.py
index bdad38643b9..55436748d6f 100644
--- a/Lib/test/test_inspect.py
+++ b/Lib/test/test_inspect.py
@@ -1564,7 +1564,7 @@ class TestGetattrStatic(unittest.TestCase):
foo.__dict__['d'] = 1
self.assertEqual(inspect.getattr_static(foo, 'd'), 1)
- # if the descriptor is a data-desciptor we should return the
+ # if the descriptor is a data-descriptor we should return the
# descriptor
descriptor.__set__ = lambda s, i, v: None
self.assertEqual(inspect.getattr_static(foo, 'd'), Foo.__dict__['d'])
diff --git a/Lib/test/test_io.py b/Lib/test/test_io.py
index c81672325ba..42dbbd35dc9 100644
--- a/Lib/test/test_io.py
+++ b/Lib/test/test_io.py
@@ -568,8 +568,8 @@ class IOTest(unittest.TestCase):
self.read_ops(f, True)
def test_large_file_ops(self):
- # On Windows and Mac OSX this test comsumes large resources; It takes
- # a long time to build the >2GB file and takes >2GB of disk space
+ # On Windows and Mac OSX this test consumes large resources; It takes
+ # a long time to build the >2 GiB file and takes >2 GiB of disk space
# therefore the resource must be enabled to run this test.
if sys.platform[:3] == 'win' or sys.platform == 'darwin':
support.requires(
diff --git a/Lib/test/test_largefile.py b/Lib/test/test_largefile.py
index 5b276e76ff2..d07bb8eee5a 100644
--- a/Lib/test/test_largefile.py
+++ b/Lib/test/test_largefile.py
@@ -141,8 +141,8 @@ def setUpModule():
except (ImportError, AttributeError):
pass
- # On Windows and Mac OSX this test comsumes large resources; It
- # takes a long time to build the >2GB file and takes >2GB of disk
+ # On Windows and Mac OSX this test consumes large resources; It
+ # takes a long time to build the >2 GiB file and takes >2 GiB of disk
# space therefore the resource must be enabled to run this test.
# If not, nothing after this line stanza will be executed.
if sys.platform[:3] == 'win' or sys.platform == 'darwin':
diff --git a/Lib/test/test_logging.py b/Lib/test/test_logging.py
index b325f7697f7..fc067138c3b 100644
--- a/Lib/test/test_logging.py
+++ b/Lib/test/test_logging.py
@@ -174,7 +174,7 @@ class BuiltinLevelsTest(BaseTest):
"""Test builtin levels and their inheritance."""
def test_flat(self):
- #Logging levels in a flat logger namespace.
+ # Logging levels in a flat logger namespace.
m = self.next_message
ERR = logging.getLogger("ERR")
@@ -244,7 +244,7 @@ class BuiltinLevelsTest(BaseTest):
])
def test_nested_inherited(self):
- #Logging levels in a nested namespace, inherited from parent loggers.
+ # Logging levels in a nested namespace, inherited from parent loggers.
m = self.next_message
INF = logging.getLogger("INF")
@@ -1901,9 +1901,9 @@ class EncodingTest(BaseTest):
def test_encoding_cyrillic_unicode(self):
log = logging.getLogger("test")
- #Get a message in Unicode: Do svidanya in Cyrillic (meaning goodbye)
+ # Get a message in Unicode: Do svidanya in Cyrillic (meaning goodbye)
message = '\u0434\u043e \u0441\u0432\u0438\u0434\u0430\u043d\u0438\u044f'
- #Ensure it's written in a Cyrillic encoding
+ # Ensure it's written in a Cyrillic encoding
writer_class = codecs.getwriter('cp1251')
writer_class.encoding = 'cp1251'
stream = io.BytesIO()
@@ -1917,7 +1917,7 @@ class EncodingTest(BaseTest):
handler.close()
# check we wrote exactly those bytes, ignoring trailing \n etc
s = stream.getvalue()
- #Compare against what the data should be when encoded in CP-1251
+ # Compare against what the data should be when encoded in CP-1251
self.assertEqual(s, b'\xe4\xee \xf1\xe2\xe8\xe4\xe0\xed\xe8\xff\n')
@@ -1938,7 +1938,7 @@ class WarningsTest(BaseTest):
h.close()
self.assertGreater(s.find("UserWarning: I'm warning you...\n"), 0)
- #See if an explicit file uses the original implementation
+ # See if an explicit file uses the original implementation
a_file = io.StringIO()
warnings.showwarning("Explicit", UserWarning, "dummy.py", 42,
a_file, "Dummy line")
@@ -2079,7 +2079,7 @@ class ConfigDictTest(BaseTest):
},
}
- #As config1 but with a misspelt level on a handler
+ # As config1 but with a misspelt level on a handler
config2a = {
'version': 1,
'formatters': {
@@ -2107,7 +2107,7 @@ class ConfigDictTest(BaseTest):
}
- #As config1 but with a misspelt level on a logger
+ # As config1 but with a misspelt level on a logger
config2b = {
'version': 1,
'formatters': {
@@ -2274,8 +2274,8 @@ class ConfigDictTest(BaseTest):
},
}
- #config 7 does not define compiler.parser but defines compiler.lexer
- #so compiler.parser should be disabled after applying it
+ # config 7 does not define compiler.parser but defines compiler.lexer
+ # so compiler.parser should be disabled after applying it
config7 = {
'version': 1,
'formatters': {
@@ -2420,7 +2420,7 @@ class ConfigDictTest(BaseTest):
},
}
- #As config1 but with a filter added
+ # As config1 but with a filter added
config10 = {
'version': 1,
'formatters': {
@@ -2454,7 +2454,7 @@ class ConfigDictTest(BaseTest):
},
}
- #As config1 but using cfg:// references
+ # As config1 but using cfg:// references
config11 = {
'version': 1,
'true_formatters': {
@@ -2485,7 +2485,7 @@ class ConfigDictTest(BaseTest):
},
}
- #As config11 but missing the version key
+ # As config11 but missing the version key
config12 = {
'true_formatters': {
'form1' : {
@@ -2515,7 +2515,7 @@ class ConfigDictTest(BaseTest):
},
}
- #As config11 but using an unsupported version
+ # As config11 but using an unsupported version
config13 = {
'version': 2,
'true_formatters': {
@@ -2716,7 +2716,7 @@ class ConfigDictTest(BaseTest):
# Original logger output is empty.
self.assert_log_lines([])
- #Same as test_config_7_ok but don't disable old loggers.
+ # Same as test_config_7_ok but don't disable old loggers.
def test_config_8_ok(self):
with support.captured_stdout() as output:
self.apply_config(self.config1)
@@ -2797,15 +2797,15 @@ class ConfigDictTest(BaseTest):
with support.captured_stdout() as output:
self.apply_config(self.config9)
logger = logging.getLogger("compiler.parser")
- #Nothing will be output since both handler and logger are set to WARNING
+ # Nothing will be output since both handler and logger are set to WARNING
logger.info(self.next_message())
self.assert_log_lines([], stream=output)
self.apply_config(self.config9a)
- #Nothing will be output since both handler is still set to WARNING
+ # Nothing will be output since handler is still set to WARNING
logger.info(self.next_message())
self.assert_log_lines([], stream=output)
self.apply_config(self.config9b)
- #Message should now be output
+ # Message should now be output
logger.info(self.next_message())
self.assert_log_lines([
('INFO', '3'),
@@ -2817,13 +2817,13 @@ class ConfigDictTest(BaseTest):
logger = logging.getLogger("compiler.parser")
logger.warning(self.next_message())
logger = logging.getLogger('compiler')
- #Not output, because filtered
+ # Not output, because filtered
logger.warning(self.next_message())
logger = logging.getLogger('compiler.lexer')
- #Not output, because filtered
+ # Not output, because filtered
logger.warning(self.next_message())
logger = logging.getLogger("compiler.parser.codegen")
- #Output, as not filtered
+ # Output, as not filtered
logger.error(self.next_message())
self.assert_log_lines([
('WARNING', '1'),
@@ -2884,13 +2884,13 @@ class ConfigDictTest(BaseTest):
logger = logging.getLogger("compiler.parser")
logger.warning(self.next_message())
logger = logging.getLogger('compiler')
- #Not output, because filtered
+ # Not output, because filtered
logger.warning(self.next_message())
logger = logging.getLogger('compiler.lexer')
- #Not output, because filtered
+ # Not output, because filtered
logger.warning(self.next_message())
logger = logging.getLogger("compiler.parser.codegen")
- #Output, as not filtered
+ # Output, as not filtered
logger.error(self.next_message())
self.assert_log_lines([
('WARNING', '1'),
@@ -4244,7 +4244,7 @@ class TimedRotatingFileHandlerTest(BaseFileTest):
break
msg = 'No rotated files found, went back %d seconds' % GO_BACK
if not found:
- #print additional diagnostics
+ # print additional diagnostics
dn, fn = os.path.split(self.fn)
files = [f for f in os.listdir(dn) if f.startswith(fn)]
print('Test time: %s' % now.strftime("%Y-%m-%d %H-%M-%S"), file=sys.stderr)
diff --git a/Lib/test/test_math.py b/Lib/test/test_math.py
index eaa41bca3f6..e6e30802887 100644
--- a/Lib/test/test_math.py
+++ b/Lib/test/test_math.py
@@ -1288,7 +1288,7 @@ class MathTests(unittest.TestCase):
class IsCloseTests(unittest.TestCase):
- isclose = math.isclose # sublcasses should override this
+ isclose = math.isclose # subclasses should override this
def assertIsClose(self, a, b, *args, **kwargs):
self.assertTrue(self.isclose(a, b, *args, **kwargs),
diff --git a/Lib/test/test_parser.py b/Lib/test/test_parser.py
index 70cabb28598..4a3571df185 100644
--- a/Lib/test/test_parser.py
+++ b/Lib/test/test_parser.py
@@ -30,7 +30,7 @@ class RoundtripLegalSyntaxTestCase(unittest.TestCase):
self.roundtrip(parser.expr, s)
def test_flags_passed(self):
- # The unicode literals flags has to be passed from the paser to AST
+ # The unicode literals flags has to be passed from the parser to AST
# generation.
suite = parser.suite("from __future__ import unicode_literals; x = ''")
code = suite.compile()
diff --git a/Lib/test/test_random.py b/Lib/test/test_random.py
index b42bf2a7124..3e57a82b63e 100644
--- a/Lib/test/test_random.py
+++ b/Lib/test/test_random.py
@@ -22,7 +22,7 @@ class TestBasicOps:
self.gen.seed()
state1 = self.gen.getstate()
time.sleep(0.1)
- self.gen.seed() # diffent seeds at different times
+ self.gen.seed() # different seeds at different times
state2 = self.gen.getstate()
self.assertNotEqual(state1, state2)
diff --git a/Lib/test/test_site.py b/Lib/test/test_site.py
index 4029617aa1d..dce2aac909d 100644
--- a/Lib/test/test_site.py
+++ b/Lib/test/test_site.py
@@ -259,7 +259,7 @@ class HelperFunctionsTests(unittest.TestCase):
'site-packages')
self.assertEqual(dirs[1], wanted)
elif os.sep == '/':
- # OS X non-framwework builds, Linux, FreeBSD, etc
+ # OS X non-framework builds, Linux, FreeBSD, etc
self.assertEqual(len(dirs), 1)
wanted = os.path.join('xoxo', 'lib',
'python%d.%d' % sys.version_info[:2],
diff --git a/Lib/test/test_socket.py b/Lib/test/test_socket.py
index a79ebfe9a34..00237626d6c 100644
--- a/Lib/test/test_socket.py
+++ b/Lib/test/test_socket.py
@@ -1357,7 +1357,7 @@ class GeneralModuleTests(unittest.TestCase):
socket.gethostbyname(domain)
socket.gethostbyname_ex(domain)
socket.getaddrinfo(domain,0,socket.AF_UNSPEC,socket.SOCK_STREAM)
- # this may not work if the forward lookup choses the IPv6 address, as that doesn't
+ # this may not work if the forward lookup chooses the IPv6 address, as that doesn't
# have a reverse entry yet
# socket.gethostbyaddr('испытание.python.org')
@@ -4239,7 +4239,7 @@ class UnbufferedFileObjectClassTestCase(FileObjectClassTestCase):
self.write_file.write(self.write_msg)
self.write_file.flush()
self.evt2.set()
- # Avoid cloding the socket before the server test has finished,
+ # Avoid closing the socket before the server test has finished,
# otherwise system recv() will return 0 instead of EWOULDBLOCK.
self.serv_finished.wait(5.0)
diff --git a/Lib/test/test_ssl.py b/Lib/test/test_ssl.py
index 54644e1596c..daffaf7af87 100644
--- a/Lib/test/test_ssl.py
+++ b/Lib/test/test_ssl.py
@@ -829,7 +829,7 @@ class BasicSocketTests(unittest.TestCase):
self.cert_time_ok("Jan 5 09:34:61 2018 GMT", 1515144901)
self.cert_time_fail("Jan 5 09:34:62 2018 GMT") # invalid seconds
- # no special treatement for the special value:
+ # no special treatment for the special value:
# 99991231235959Z (rfc 5280)
self.cert_time_ok("Dec 31 23:59:59 9999 GMT", 253402300799.0)
diff --git a/Lib/test/test_sys_settrace.py b/Lib/test/test_sys_settrace.py
index 25c5835fd6f..ec537bee91c 100644
--- a/Lib/test/test_sys_settrace.py
+++ b/Lib/test/test_sys_settrace.py
@@ -16,7 +16,7 @@ basic.events = [(0, 'call'),
# Many of the tests below are tricky because they involve pass statements.
# If there is implicit control flow around a pass statement (in an except
-# clause or else caluse) under what conditions do you set a line number
+# clause or else clause) under what conditions do you set a line number
# following that clause?
diff --git a/Lib/test/test_xml_etree.py b/Lib/test/test_xml_etree.py
index 7adfbdfd7a9..f8af69fa110 100644
--- a/Lib/test/test_xml_etree.py
+++ b/Lib/test/test_xml_etree.py
@@ -2280,7 +2280,7 @@ class ElementIterTest(unittest.TestCase):
sourcefile = serialize(doc, to_string=False)
self.assertEqual(next(ET.iterparse(sourcefile))[0], 'end')
- # With an explitit parser too (issue #9708)
+ # With an explicit parser too (issue #9708)
sourcefile = serialize(doc, to_string=False)
parser = ET.XMLParser(target=ET.TreeBuilder())
self.assertEqual(next(ET.iterparse(sourcefile, parser=parser))[0],
diff --git a/Lib/test/test_zipapp.py b/Lib/test/test_zipapp.py
index d8d44375bdd..4607f57afc3 100644
--- a/Lib/test/test_zipapp.py
+++ b/Lib/test/test_zipapp.py
@@ -311,7 +311,7 @@ class ZipAppCmdlineTest(unittest.TestCase):
args = [str(original), '-o', str(original)]
with self.assertRaises(SystemExit) as cm:
zipapp.main(args)
- # Program should exit with a non-zero returm code.
+ # Program should exit with a non-zero return code.
self.assertTrue(cm.exception.code)
def test_cmdline_copy_change_main(self):
@@ -321,7 +321,7 @@ class ZipAppCmdlineTest(unittest.TestCase):
args = [str(original), '-o', str(target), '-m', 'foo:bar']
with self.assertRaises(SystemExit) as cm:
zipapp.main(args)
- # Program should exit with a non-zero returm code.
+ # Program should exit with a non-zero return code.
self.assertTrue(cm.exception.code)
@patch('sys.stdout', new_callable=io.StringIO)
@@ -331,7 +331,7 @@ class ZipAppCmdlineTest(unittest.TestCase):
args = [str(target), '--info']
with self.assertRaises(SystemExit) as cm:
zipapp.main(args)
- # Program should exit with a zero returm code.
+ # Program should exit with a zero return code.
self.assertEqual(cm.exception.code, 0)
self.assertEqual(mock_stdout.getvalue(), "Interpreter: <none>\n")
@@ -341,7 +341,7 @@ class ZipAppCmdlineTest(unittest.TestCase):
args = [str(target), '--info']
with self.assertRaises(SystemExit) as cm:
zipapp.main(args)
- # Program should exit with a non-zero returm code.
+ # Program should exit with a non-zero return code.
self.assertTrue(cm.exception.code)
diff --git a/Lib/tkinter/test/test_ttk/test_functions.py b/Lib/tkinter/test/test_ttk/test_functions.py
index a1b7cdfcd14..f8e69a9f416 100644
--- a/Lib/tkinter/test/test_ttk/test_functions.py
+++ b/Lib/tkinter/test/test_ttk/test_functions.py
@@ -149,7 +149,7 @@ class InternalFunctionsTest(unittest.TestCase):
# but when passing a single state, it can be anything
valid = {'opt': [[1, 'value']]}
self.assertEqual(ttk._format_mapdict(valid), ('-opt', '1 value'))
- # special attention to single states which evalute to False
+ # special attention to single states which evaluate to False
for stateval in (None, 0, False, '', set()): # just some samples
valid = {'opt': [(stateval, 'value')]}
self.assertEqual(ttk._format_mapdict(valid),
@@ -251,7 +251,7 @@ class InternalFunctionsTest(unittest.TestCase):
self.assertEqual(ttk._format_layoutlist([])[0], '')
# _format_layoutlist always expects the second item (in every item)
- # to act like a dict (except when the value evalutes to False).
+ # to act like a dict (except when the value evaluates to False).
self.assertRaises(AttributeError,
ttk._format_layoutlist, [('a', 'b')])
diff --git a/Lib/tkinter/ttk.py b/Lib/tkinter/ttk.py
index 635b500579e..42e29bd3e5c 100644
--- a/Lib/tkinter/ttk.py
+++ b/Lib/tkinter/ttk.py
@@ -83,7 +83,7 @@ def _mapdict_values(items):
# ['active selected', 'grey', 'focus', [1, 2, 3, 4]]
opt_val = []
for *state, val in items:
- # hacks for bakward compatibility
+ # hacks for backward compatibility
state[0] # raise IndexError if empty
if len(state) == 1:
# if it is empty (something that evaluates to False), then
diff --git a/Lib/turtledemo/__main__.py b/Lib/turtledemo/__main__.py
index 6daf694427d..17fe9a75e1c 100644
--- a/Lib/turtledemo/__main__.py
+++ b/Lib/turtledemo/__main__.py
@@ -259,7 +259,7 @@ class DemoWindow(object):
return 'break'
def update_mousewheel(self, event):
- # For wheel up, event.delte = 120 on Windows, -1 on darwin.
+ # For wheel up, event.delta = 120 on Windows, -1 on darwin.
# X-11 sends Control-Button-4 event instead.
if (event.delta < 0) == (not darwin):
return self.decrease_size()
diff --git a/Lib/unittest/test/testmock/testmagicmethods.py b/Lib/unittest/test/testmock/testmagicmethods.py
index 24569b532de..4186c8e967c 100644
--- a/Lib/unittest/test/testmock/testmagicmethods.py
+++ b/Lib/unittest/test/testmock/testmagicmethods.py
@@ -450,7 +450,7 @@ class TestMockingMagicMethods(unittest.TestCase):
self.assertIsInstance(bar_direct, MagicMock)
# http://bugs.python.org/issue23310
- # Check if you can change behaviour of magic methds in MagicMock init
+ # Check if you can change behaviour of magic methods in MagicMock init
def test_magic_in_initialization(self):
m = MagicMock(**{'__str__.return_value': "12"})
self.assertEqual(str(m), "12")
diff --git a/Lib/xml/etree/ElementTree.py b/Lib/xml/etree/ElementTree.py
index 735405681ff..cf4e1da9766 100644
--- a/Lib/xml/etree/ElementTree.py
+++ b/Lib/xml/etree/ElementTree.py
@@ -1061,7 +1061,7 @@ def _escape_cdata(text):
# escape character data
try:
# it's worth avoiding do-nothing calls for strings that are
- # shorter than 500 character, or so. assume that's, by far,
+ # shorter than 500 characters, or so. assume that's, by far,
# the most common case in most applications.
if "&" in text:
text = text.replace("&", "&amp;")
diff --git a/Lib/xmlrpc/client.py b/Lib/xmlrpc/client.py
index bd3278e005a..88ee551f125 100644
--- a/Lib/xmlrpc/client.py
+++ b/Lib/xmlrpc/client.py
@@ -1127,7 +1127,7 @@ class Transport:
accept_gzip_encoding = True
# if positive, encode request using gzip if it exceeds this threshold
- # note that many server will get confused, so only use it if you know
+ # note that many servers will get confused, so only use it if you know
# that they can decode such a request
encode_threshold = None #None = don't encode
@@ -1258,7 +1258,7 @@ class Transport:
# Send HTTP request.
#
# @param host Host descriptor (URL or (URL, x509 info) tuple).
- # @param handler Targer RPC handler (a path relative to host)
+ # @param handler Target RPC handler (a path relative to host)
# @param request_body The XML-RPC request body
# @param debug Enable debugging if debug is true.
# @return An HTTPConnection.
diff --git a/Mac/BuildScript/build-installer.py b/Mac/BuildScript/build-installer.py
index 52f391a4316..ff02fb37126 100755
--- a/Mac/BuildScript/build-installer.py
+++ b/Mac/BuildScript/build-installer.py
@@ -1080,7 +1080,7 @@ def buildLibraries():
def buildPythonDocs():
# This stores the documentation as Resources/English.lproj/Documentation
- # inside the framwork. pydoc and IDLE will pick it up there.
+ # inside the framework. pydoc and IDLE will pick it up there.
print("Install python documentation")
rootDir = os.path.join(WORKDIR, '_root')
buildDir = os.path.join('../../Doc')
diff --git a/Modules/faulthandler.c b/Modules/faulthandler.c
index 92aa1d444bb..227424f8bba 100644
--- a/Modules/faulthandler.c
+++ b/Modules/faulthandler.c
@@ -1036,7 +1036,7 @@ faulthandler_fatal_error_c_thread(PyObject *self, PyObject *args)
}
/* wait until the thread completes: it will never occur, since Py_FatalError()
- exits the process immedialty. */
+ exits the process immediately. */
PyThread_acquire_lock(lock, WAIT_LOCK);
PyThread_release_lock(lock);
PyThread_free_lock(lock);
diff --git a/setup.py b/setup.py
index 0d644db8573..5e2b81bbb6b 100644
--- a/setup.py
+++ b/setup.py
@@ -1391,7 +1391,7 @@ class PyBuildExt(build_ext):
if host_platform == 'darwin':
# On OS X, there is no separate /usr/lib/libncursesw nor
# libpanelw. If we are here, we found a locally-supplied
- # version of libncursesw. There should be also be a
+ # version of libncursesw. There should also be a
# libpanelw. _XOPEN_SOURCE defines are usually excluded
# for OS X but we need _XOPEN_SOURCE_EXTENDED here for
# ncurses wide char support