summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Fearn <jfearn@redhat.com>2021-05-27 08:50:05 +1000
committerJeff Fearn <jfearn@redhat.com>2021-05-27 08:50:05 +1000
commite5518022537ff959726cc2865bf93f46cdf15659 (patch)
tree5cbd1b76d61fb134097ec798a91e65f981f70130
parentBug 1964187 - Bot check preventing password change for real users (diff)
downloadbugzilla-e5518022537ff959726cc2865bf93f46cdf15659.tar.gz
bugzilla-e5518022537ff959726cc2865bf93f46cdf15659.tar.bz2
bugzilla-e5518022537ff959726cc2865bf93f46cdf15659.zip
Bug 1959199 - Hyperlinks to bugs missing in recent release notes
Fix links. Fix script that generates links. Change-Id: I135ff27288fa0f7df37f08375a656527cb0b9deb
-rwxr-xr-xextensions/RedHat/bin/release.pl3
-rw-r--r--extensions/RedHat/template/en/default/hook/pages/release-notes-updates_top.html.tmpl36
2 files changed, 19 insertions, 20 deletions
diff --git a/extensions/RedHat/bin/release.pl b/extensions/RedHat/bin/release.pl
index 8e2a110c9..02c3f4d23 100755
--- a/extensions/RedHat/bin/release.pl
+++ b/extensions/RedHat/bin/release.pl
@@ -48,7 +48,7 @@ my $email = qx/git config --get user.email/;
chomp($email);
$cmd
- = qq{git log $curr_tag..HEAD --no-merges --format=" <li>%s</li>" | grep -E 'li>Bug \\d+' | sort -u };
+ = qq{git log $curr_tag..HEAD --no-merges --format=" <li>\%s</li>" | grep -E 'li>Bug [0-9]+' | sort -u };
my $html_log = qx/$cmd/;
$html_log =~ s{Bug (\d+)}{<a href="https://bugzilla.redhat.com/$1">Bug $1</a>}g;
$html_log =~ s{a>\s*-\s*}{a> }g;
@@ -70,7 +70,6 @@ now run:
git commit -a -m "Release Version $version"
git tag -a "Release-$version" -m "Release Version $version"
git push --follow-tags
-make -f extensions/RedHat/Makefile rhpkg
git checkout devel-5.0
git merge master
git push
diff --git a/extensions/RedHat/template/en/default/hook/pages/release-notes-updates_top.html.tmpl b/extensions/RedHat/template/en/default/hook/pages/release-notes-updates_top.html.tmpl
index 36806cc78..01bb5751a 100644
--- a/extensions/RedHat/template/en/default/hook/pages/release-notes-updates_top.html.tmpl
+++ b/extensions/RedHat/template/en/default/hook/pages/release-notes-updates_top.html.tmpl
@@ -1,27 +1,27 @@
<h3 id='5.0.4-rh56'>5.0.4-rh56</h3>
<ul>
- <li>Bug 1955079 - internal bot regex is wrong</li>
+ <li><a href="https://bugzilla.redhat.com/1955079">Bug 1955079</a> - internal bot regex is wrong</li>
</ul>
<h3 id='5.0.4-rh55'>5.0.4-rh55</h3>
<ul>
- <li>Bug 1827659 - team creation ignores group settings for non-admin users</li>
- <li>Bug 1858614 - Searching for Link IDs is pretty weak</li>
- <li>Bug 1891728 - Process sub-addresses when closing accounts</li>
- <li>Bug 1903844 - expose is_active</li>
- <li>Bug 1903845 - Add link to component admin page</li>
- <li>Bug 1912844 - Typo in the `Using Bugzilla API` section in FAQ</li>
- <li>Bug 1915821 - Selecting a subcomponent when reporting a new bug doesn't fill in default assignee/QA contact</li>
- <li>Bug 1931517 - Add a gitlab connector</li>
- <li>Bug 1932156 - Support creation of bot accounts</li>
- <li>Bug 1941887 - Invalid Content-Type 'subtype' parameter errors</li>
- <li>Bug 1942233 - Radius message should mention SSO</li>
- <li>Bug 1942247 - Redirection through SSO login loses bugzilla URL parameters after the first</li>
- <li>Bug 1943290 - Cannot distinguish visited and unvisited links</li>
- <li>Bug 1944984 - Implement "Last changed from" condition for an advanced/custom search</li>
- <li>Bug 1946158 - agile_team.name not supported</li>
- <li>Bug 1947325 - Under load creating a bug can trigger a serializations error</li>
- <li>Bug 1948338 - Move from Radius to PrivacyIDEA</li>
+ <li><a href="https://bugzilla.redhat.com/1827659">Bug 1827659</a> - team creation ignores group settings for non-admin users</li>
+ <li><a href="https://bugzilla.redhat.com/1858614">Bug 1858614</a> - Searching for Link IDs is pretty weak</li>
+ <li><a href="https://bugzilla.redhat.com/1891728">Bug 1891728</a> - Process sub-addresses when closing accounts</li>
+ <li><a href="https://bugzilla.redhat.com/1903844">Bug 1903844</a> - expose is_active</li>
+ <li><a href="https://bugzilla.redhat.com/1903845">Bug 1903845</a> - Add link to component admin page</li>
+ <li><a href="https://bugzilla.redhat.com/1912844">Bug 1912844</a> - Typo in the `Using Bugzilla API` section in FAQ</li>
+ <li><a href="https://bugzilla.redhat.com/1915821">Bug 1915821</a> - Selecting a subcomponent when reporting a new bug doesn't fill in default assignee/QA contact</li>
+ <li><a href="https://bugzilla.redhat.com/1931517">Bug 1931517</a> - Add a gitlab connector</li>
+ <li><a href="https://bugzilla.redhat.com/1932156">Bug 1932156</a> - Support creation of bot accounts</li>
+ <li><a href="https://bugzilla.redhat.com/1941887">Bug 1941887</a> - Invalid Content-Type 'subtype' parameter errors</li>
+ <li><a href="https://bugzilla.redhat.com/1942233">Bug 1942233</a> - Radius message should mention SSO</li>
+ <li><a href="https://bugzilla.redhat.com/1942247">Bug 1942247</a> - Redirection through SSO login loses bugzilla URL parameters after the first</li>
+ <li><a href="https://bugzilla.redhat.com/1943290">Bug 1943290</a> - Cannot distinguish visited and unvisited links</li>
+ <li><a href="https://bugzilla.redhat.com/1944984">Bug 1944984</a> - Implement "Last changed from" condition for an advanced/custom search</li>
+ <li><a href="https://bugzilla.redhat.com/1946158">Bug 1946158</a> - agile_team.name not supported</li>
+ <li><a href="https://bugzilla.redhat.com/1947325">Bug 1947325</a> - Under load creating a bug can trigger a serializations error</li>
+ <li><a href="https://bugzilla.redhat.com/1948338">Bug 1948338</a> - Move from Radius to PrivacyIDEA</li>
</ul>
<h3 id='5.0.4-rh54'>5.0.4-rh54</h3>