aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Geissler <romain.geissler@amadeus.com>2023-02-05 13:56:34 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2023-02-08 22:05:34 +0100
commitc15e70a0f42eb53f10ce4a98093cc942e1fae7be (patch)
tree5d42ebfb442e6b82e9e870b2526ab7e674439c3c
parentbpf: fix error conversion from long unsigned int to unsigned int [-Werror=ove... (diff)
downloadbinutils-gdb-c15e70a0f42eb53f10ce4a98093cc942e1fae7be.tar.gz
binutils-gdb-c15e70a0f42eb53f10ce4a98093cc942e1fae7be.tar.bz2
binutils-gdb-c15e70a0f42eb53f10ce4a98093cc942e1fae7be.zip
Pass $JANSSON_LIBS and $ZSTD_LIBS to ld-bootstrap/bootrap.exp
(cherry picked from commit e1815414077347097e5bf0d75162add955e241d9)
-rw-r--r--ld/Makefile.am1
-rw-r--r--ld/Makefile.in1
-rw-r--r--ld/testsuite/ld-bootstrap/bootstrap.exp4
3 files changed, 4 insertions, 2 deletions
diff --git a/ld/Makefile.am b/ld/Makefile.am
index 12b2c3c453f..b3195b4be68 100644
--- a/ld/Makefile.am
+++ b/ld/Makefile.am
@@ -992,6 +992,7 @@ check-DEJAGNU: site.exp
CXXFLAGS_FOR_TARGET="$(CXXFLAGS_FOR_TARGET)" \
OFILES="$(OFILES)" BFDLIB="$(TESTBFDLIB)" CTFLIB="$(TESTCTFLIB) $(ZLIB)" \
SFRAMELIB="$(TESTSFRAMELIB)" \
+ JANSSON_LIBS="$(JANSSON_LIBS)" ZSTD_LIBS="$(ZSTD_LIBS)" \
LIBIBERTY="$(LIBIBERTY) $(LIBINTL)" LIBS="$(LIBS)" \
DO_COMPARE="`echo '$(do_compare)' | sed -e 's,\\$$,,g'`" \
$(RUNTESTFLAGS); \
diff --git a/ld/Makefile.in b/ld/Makefile.in
index 3d5685d6bae..fe422569228 100644
--- a/ld/Makefile.in
+++ b/ld/Makefile.in
@@ -2645,6 +2645,7 @@ check-DEJAGNU: site.exp
CXXFLAGS_FOR_TARGET="$(CXXFLAGS_FOR_TARGET)" \
OFILES="$(OFILES)" BFDLIB="$(TESTBFDLIB)" CTFLIB="$(TESTCTFLIB) $(ZLIB)" \
SFRAMELIB="$(TESTSFRAMELIB)" \
+ JANSSON_LIBS="$(JANSSON_LIBS)" ZSTD_LIBS="$(ZSTD_LIBS)" \
LIBIBERTY="$(LIBIBERTY) $(LIBINTL)" LIBS="$(LIBS)" \
DO_COMPARE="`echo '$(do_compare)' | sed -e 's,\\$$,,g'`" \
$(RUNTESTFLAGS); \
diff --git a/ld/testsuite/ld-bootstrap/bootstrap.exp b/ld/testsuite/ld-bootstrap/bootstrap.exp
index 7e95ddd76e9..b189a0c7098 100644
--- a/ld/testsuite/ld-bootstrap/bootstrap.exp
+++ b/ld/testsuite/ld-bootstrap/bootstrap.exp
@@ -162,13 +162,13 @@ foreach flags $test_flags {
}
if { [lindex [remote_exec build grep "-q \"HAVE_ZSTD 1\" config.h" ] 0] == 0 } then {
- set extralibs "$extralibs -lzstd"
+ set extralibs "$extralibs $ZSTD_LIBS"
}
# Check if the system's jansson library is used. If so, the object files will
# be using symbols from it, so link to it.
if { [lindex [remote_exec build grep "-q \"HAVE_JANSSON 1\" config.h" ] 0] == 0 } then {
- set extralibs "$extralibs -ljansson"
+ set extralibs "$extralibs $JANSSON_LIBS"
}
# Plugin support requires linking with libdl.