summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5.ebuild')
-rw-r--r--hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5.ebuild b/hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5.ebuild
index be1cba8..b016791 100644
--- a/hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5.ebuild
+++ b/hardened/toolchain/branches/pieworld/sys-libs/glibc/glibc-2.5.ebuild
@@ -218,9 +218,6 @@ toolchain-glibc_src_unpack() {
echo "Gentoo patchset ${PATCH_VER}" > csu/Banner
fi
- einfo "Patching to make test failures clear, and to run all of them."
- epatch ${FILESDIR}/2.4/glibc-2.4-testfailobvious.patch
-
if use hardened; then
einfo "Patching to get working PIE binaries on PIE (hardened) platforms"
# This patch forces all links to use the PIC crtfiles, to build PIEs.
@@ -309,7 +306,11 @@ toolchain-glibc_headers_compile() {
toolchain-glibc_src_test() {
cd "${WORKDIR}"/build-${ABI}-${CTARGET}-$1 || die "cd build-${ABI}-${CTARGET}-$1"
unset LD_ASSUME_KERNEL
- make check || ewarn "make check failed for ${ABI}-${CTARGET}-$1"
+ make check && return
+ einfo "make check failed - re-running with --ignore-errors to get the rest of the results."
+ make --ignore-errors check
+ ewarn "make check failed for ${ABI}-${CTARGET}-$1"
+ return 1
}
toolchain-glibc_pkg_preinst() {
@@ -1183,8 +1184,14 @@ src_test() {
return 0
fi
- want_linuxthreads && toolchain-glibc_src_test linuxthreads
- want_nptl && toolchain-glibc_src_test nptl
+ local ok=0
+ if want_linuxthreads; then
+ toolchain-glibc_src_test linuxthreads || ok=1
+ fi
+ if want_nptl; then
+ toolchain-glibc_src_test nptl || ok=1
+ fi
+ [[ ${ok} == "0" ]] || die "Tests did not all pass :("
}
src_strip() {