# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-im/pyicq-t/pyicq-t-0.8a.ebuild,v 1.4 2008/05/29 17:39:42 hawking Exp $
NEED_PYTHON=2.3
inherit eutils multilib python
DESCRIPTION="Python based jabber transport for ICQ"
HOMEPAGE="http://pyicq-t.blathersource.org/"
SRC_URI="http://www.blathersource.org/download.php/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 x86"
IUSE="webinterface"
DEPEND="net-im/jabber-base"
RDEPEND="${DEPEND}
>=dev-python/twisted-2.2.0
>=dev-python/twisted-words-0.1.0
>=dev-python/twisted-web-0.5.0
webinterface? ( >=dev-python/nevow-0.4.1 )
>=dev-python/imaging-1.1"
src_unpack() {
unpack ${A} && cd "${S}" || die "unpack failed"
epatch "${FILESDIR}/${PN}-0.8-twisted-2.5.patch"
}
src_install() {
local inspath
python_version
inspath=/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
insinto ${inspath}
doins -r data src tools
newins PyICQt.py ${PN}.py
insinto /etc/jabber
newins config_example.xml ${PN}.xml
fperms 600 /etc/jabber/${PN}.xml
fowners jabber:jabber /etc/jabber/${PN}.xml
dosed \
"s:[^\<]*:/var/spool/jabber:" \
/etc/jabber/${PN}.xml
dosed \
"s:[^\<]*:/var/run/jabber/${PN}.pid:" \
/etc/jabber/${PN}.xml
newinitd "${FILESDIR}/${PN}-0.8-initd" ${PN}
dosed "s:INSPATH:${inspath}:" /etc/init.d/${PN}
}
pkg_postinst() {
python_version
python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
elog "A sample configuration file has been installed in /etc/jabber/${PN}.xml."
elog "Please edit it and the configuration of your Jabber server to match."
}
pkg_postrm() {
python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/${PN}
}