From 39cea57501c56b22a288d7839eafcfb30bcd5766 Mon Sep 17 00:00:00 2001
From: Maxim Koltsov <maksbotan@gentoo.org>
Date: Thu, 21 Jul 2011 11:12:03 +0000
Subject: Misc updates to set-opacity-1.0, add 9999. See #276913

(Portage version: 2.1.10.6/cvs/Linux i686)
---
 x11-misc/set_opacity/ChangeLog               |  9 +++++++-
 x11-misc/set_opacity/set_opacity-1.0.ebuild  | 22 +++++++++----------
 x11-misc/set_opacity/set_opacity-9999.ebuild | 33 ++++++++++++++++++++++++++++
 3 files changed, 51 insertions(+), 13 deletions(-)
 create mode 100644 x11-misc/set_opacity/set_opacity-9999.ebuild

(limited to 'x11-misc/set_opacity')

diff --git a/x11-misc/set_opacity/ChangeLog b/x11-misc/set_opacity/ChangeLog
index 1b6c47a59b8a..eb3478e9050e 100644
--- a/x11-misc/set_opacity/ChangeLog
+++ b/x11-misc/set_opacity/ChangeLog
@@ -1,6 +1,13 @@
 # ChangeLog for x11-misc/set_opacity
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/set_opacity/ChangeLog,v 1.1 2011/07/18 10:10:10 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/set_opacity/ChangeLog,v 1.2 2011/07/21 11:12:03 maksbotan Exp $
+
+*set_opacity-9999 (21 Jul 2011)
+
+  21 Jul 2011; Maxim Koltsov (maksbotan) <maksbotan@gentoo.org>
+  set_opacity-1.0.ebuild, +set_opacity-9999.ebuild:
+  Change set_opacity-1.0 to use new homepage and SRC_URI, updated to EAPI="4",
+  added live ebuild. See bug #276913
 
 *set_opacity-1.0 (18 Jul 2011)
 
diff --git a/x11-misc/set_opacity/set_opacity-1.0.ebuild b/x11-misc/set_opacity/set_opacity-1.0.ebuild
index 995d9601aa58..337f7ca377c3 100644
--- a/x11-misc/set_opacity/set_opacity-1.0.ebuild
+++ b/x11-misc/set_opacity/set_opacity-1.0.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/set_opacity/set_opacity-1.0.ebuild,v 1.1 2011/07/18 10:10:10 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/set_opacity/set_opacity-1.0.ebuild,v 1.2 2011/07/21 11:12:03 maksbotan Exp $
 
-EAPI="3"
+EAPI="4"
 
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
 
 DESCRIPTION="Tool for set real compositing for windows through window's id, process' pid etc."
-HOMEPAGE="http://www.xvilka.narod.ru/downloads.xhtml"
-SRC_URI="http://www.xvilka.narod.ru/files/${P}.tar.bz2"
+HOMEPAGE="https://gitorious.org/x11-tools/set_opacity"
+SRC_URI="https://gitorious.org/x11-tools/set_opacity/archive-tarball/${PV} -> ${P}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
 IUSE=""
 
 DEPEND="x11-libs/libXdamage
@@ -21,14 +21,12 @@ DEPEND="x11-libs/libXdamage
 	x11-libs/libXrender"
 RDEPEND=${DEPEND}
 
-src_prepare(){
-	epatch "${FILESDIR}"/makefile.patch
-}
+S="${WORKDIR}/x11-tools-set_opacity"
 
 src_compile() {
-	emake CC="$(tc-getCC)" || die "emake failed"
+	emake CC="$(tc-getCC)"
 }
 
 src_install() {
-	dobin set_opacity || die "dobin failed"
+	dobin set_opacity
 }
diff --git a/x11-misc/set_opacity/set_opacity-9999.ebuild b/x11-misc/set_opacity/set_opacity-9999.ebuild
new file mode 100644
index 000000000000..680ccd22c2cb
--- /dev/null
+++ b/x11-misc/set_opacity/set_opacity-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/set_opacity/set_opacity-9999.ebuild,v 1.1 2011/07/21 11:12:03 maksbotan Exp $
+
+EAPI="4"
+
+EGIT_REPO_URI="git://gitorious.org/x11-tools/set_opacity.git"
+
+inherit git-2 toolchain-funcs
+
+DESCRIPTION="Tool for set real compositing for windows through window's id, process' pid etc."
+HOMEPAGE="https://gitorious.org/x11-tools/set_opacity"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/libXdamage
+	x11-libs/libXcomposite
+	x11-libs/libXfixes
+	x11-libs/libXrender"
+RDEPEND=${DEPEND}
+
+KEYWORDS=""
+
+src_compile() {
+	emake CC="$(tc-getCC)"
+}
+
+src_install() {
+	dobin set_opacity
+}
-- 
cgit v1.2.3-65-gdbad