summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/xpra/files/xpra-0.10.1-prefix.patch')
-rw-r--r--x11-wm/xpra/files/xpra-0.10.1-prefix.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-wm/xpra/files/xpra-0.10.1-prefix.patch b/x11-wm/xpra/files/xpra-0.10.1-prefix.patch
new file mode 100644
index 000000000000..1e8e759abaca
--- /dev/null
+++ b/x11-wm/xpra/files/xpra-0.10.1-prefix.patch
@@ -0,0 +1,30 @@
+Index: xpra-0.10.1/setup.py
+===================================================================
+--- xpra-0.10.1.orig/setup.py
++++ xpra-0.10.1/setup.py
+@@ -896,8 +896,8 @@ else:
+ return {}
+ if "install" in sys.argv:
+ #prepare default [/usr/local]/etc configuration files:
+- if sys.prefix == '/usr':
+- etc_prefix = '/etc/xpra'
++ if sys.prefix[-4:] == '/usr':
++ etc_prefix = sys.prefix[:-4] + '/etc/xpra'
+ else:
+ etc_prefix = sys.prefix + '/etc/xpra'
+
+Index: xpra-0.10.1/xpra/scripts/config.py
+===================================================================
+--- xpra-0.10.1.orig/xpra/scripts/config.py
++++ xpra-0.10.1/xpra/scripts/config.py
+@@ -344,8 +344,8 @@ def read_xpra_defaults():
+ #first, read the global defaults:
+ if sys.platform.startswith("win"):
+ conf_dir = os.path.dirname(os.path.abspath(sys.executable))
+- elif sys.prefix == '/usr':
+- conf_dir = '/etc/xpra'
++ elif sys.prefix[-4:] == '/usr':
++ conf_dir = sys.prefix[:-4] + '/etc/xpra'
+ else:
+ conf_dir = sys.prefix + '/etc/xpra/'
+ defaults = read_xpra_conf(conf_dir)