summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmtz/ChangeLog7
-rw-r--r--x11-plugins/wmtz/wmtz-0.7.ebuild14
-rw-r--r--x11-plugins/wmupmon/ChangeLog8
-rw-r--r--x11-plugins/wmupmon/wmupmon-0.1.2.ebuild16
-rw-r--r--x11-plugins/wmupmon/wmupmon-0.1.3.ebuild16
-rw-r--r--x11-plugins/wmusic/ChangeLog8
-rw-r--r--x11-plugins/wmusic/wmusic-1.4.11.ebuild8
-rw-r--r--x11-plugins/wmusic/wmusic-1.5.0.ebuild8
-rw-r--r--x11-plugins/wmwave/ChangeLog7
-rw-r--r--x11-plugins/wmwave/wmwave-0.4.ebuild13
10 files changed, 70 insertions, 35 deletions
diff --git a/x11-plugins/wmtz/ChangeLog b/x11-plugins/wmtz/ChangeLog
index 26c2a2e4919d..e05e7066038d 100644
--- a/x11-plugins/wmtz/ChangeLog
+++ b/x11-plugins/wmtz/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmtz
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtz/ChangeLog,v 1.13 2005/11/13 07:18:42 morfic Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtz/ChangeLog,v 1.14 2006/01/31 21:01:53 nelchael Exp $
+
+ 31 Jan 2006; Krzysiek Pawlik <nelchael@gentoo.org> wmtz-0.7.ebuild:
+ Fixed DEPEND for modular X.
13 Nov 2005; Daniel Goller <morfic@gentoo.org> wmtz-0.7.ebuild:
Removing condition for patch, so gcc4 can compile this too
diff --git a/x11-plugins/wmtz/wmtz-0.7.ebuild b/x11-plugins/wmtz/wmtz-0.7.ebuild
index 8441cae4339e..e6f7cff8dbd4 100644
--- a/x11-plugins/wmtz/wmtz-0.7.ebuild
+++ b/x11-plugins/wmtz/wmtz-0.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtz/wmtz-0.7.ebuild,v 1.14 2005/11/13 07:18:42 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtz/wmtz-0.7.ebuild,v 1.15 2006/01/31 21:01:53 nelchael Exp $
inherit eutils toolchain-funcs
@@ -13,14 +13,20 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 amd64 ppc ~sparc"
-DEPEND="virtual/x11"
+RDEPEND="|| ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm )
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( x11-proto/xextproto virtual/x11 )"
src_unpack() {
unpack ${A}
cd ${S}
#apply both patches to compile with gcc-3.4 closing bug #64556
- epatch ${FILESDIR}/wmtz-0.7-gcc34.patch
+ epatch ${FILESDIR}/wmtz-0.7-gcc34.patch
}
src_compile() {
diff --git a/x11-plugins/wmupmon/ChangeLog b/x11-plugins/wmupmon/ChangeLog
index c6ef25c0ee7b..8f111094cf28 100644
--- a/x11-plugins/wmupmon/ChangeLog
+++ b/x11-plugins/wmupmon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmupmon
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmupmon/ChangeLog,v 1.11 2005/12/21 03:32:57 smithj Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmupmon/ChangeLog,v 1.12 2006/01/31 21:03:59 nelchael Exp $
+
+ 31 Jan 2006; Krzysiek Pawlik <nelchael@gentoo.org> wmupmon-0.1.2.ebuild,
+ wmupmon-0.1.3.ebuild:
+ Fixed DEPEND for modular X.
*wmupmon-0.1.3 (21 Dec 2005)
diff --git a/x11-plugins/wmupmon/wmupmon-0.1.2.ebuild b/x11-plugins/wmupmon/wmupmon-0.1.2.ebuild
index 8edf70d09d92..d77c56501485 100644
--- a/x11-plugins/wmupmon/wmupmon-0.1.2.ebuild
+++ b/x11-plugins/wmupmon/wmupmon-0.1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmupmon/wmupmon-0.1.2.ebuild,v 1.7 2005/11/11 11:17:11 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmupmon/wmupmon-0.1.2.ebuild,v 1.8 2006/01/31 21:03:59 nelchael Exp $
DESCRIPTION="wmUpMon is a program to monitor your Uptime"
HOMEPAGE="http://j-z-s.com/projects/index.php?project=wmupmon"
@@ -9,9 +9,15 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~sparc amd64 ppc ppc64"
IUSE=""
-DEPEND="sys-devel/automake
- sys-devel/autoconf
- virtual/x11"
+
+RDEPEND="|| ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+ x11-libs/libXpm )
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( x11-proto/xextproto virtual/x11 )"
src_compile()
{
diff --git a/x11-plugins/wmupmon/wmupmon-0.1.3.ebuild b/x11-plugins/wmupmon/wmupmon-0.1.3.ebuild
index 5e144e09237d..8a418fad21bd 100644
--- a/x11-plugins/wmupmon/wmupmon-0.1.3.ebuild
+++ b/x11-plugins/wmupmon/wmupmon-0.1.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmupmon/wmupmon-0.1.3.ebuild,v 1.1 2005/12/21 03:32:57 smithj Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmupmon/wmupmon-0.1.3.ebuild,v 1.2 2006/01/31 21:03:59 nelchael Exp $
DESCRIPTION="wmUpMon is a program to monitor your Uptime"
HOMEPAGE="http://j-z-s.com/projects/index.php?project=wmupmon"
@@ -9,9 +9,15 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~sparc ~amd64 ~ppc ~ppc64"
IUSE=""
-DEPEND="sys-devel/automake
- sys-devel/autoconf
- virtual/x11"
+
+RDEPEND="|| ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+ x11-libs/libXpm )
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( x11-proto/xextproto virtual/x11 )"
src_compile()
{
diff --git a/x11-plugins/wmusic/ChangeLog b/x11-plugins/wmusic/ChangeLog
index b7b721df182e..66ffd5a9dab4 100644
--- a/x11-plugins/wmusic/ChangeLog
+++ b/x11-plugins/wmusic/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmusic
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmusic/ChangeLog,v 1.10 2004/11/25 15:49:05 weeve Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmusic/ChangeLog,v 1.11 2006/01/31 21:05:07 nelchael Exp $
+
+ 31 Jan 2006; Krzysiek Pawlik <nelchael@gentoo.org> wmusic-1.4.11.ebuild,
+ wmusic-1.5.0.ebuild:
+ Fixed DEPEND for modular X.
25 Nov 2004; Jason Wever <weeve@gentoo.org> wmusic-1.5.0.ebuild:
Added ~sparc keyword.
diff --git a/x11-plugins/wmusic/wmusic-1.4.11.ebuild b/x11-plugins/wmusic/wmusic-1.4.11.ebuild
index e081ba9e9ccb..4eb9a74b6818 100644
--- a/x11-plugins/wmusic/wmusic-1.4.11.ebuild
+++ b/x11-plugins/wmusic/wmusic-1.4.11.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmusic/wmusic-1.4.11.ebuild,v 1.8 2004/09/22 22:42:29 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmusic/wmusic-1.4.11.ebuild,v 1.9 2006/01/31 21:05:07 nelchael Exp $
DESCRIPTION="dockapp for xmms"
HOMEPAGE="http://home.jtan.com/~john/wmusic/"
@@ -9,9 +9,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 amd64 ~ppc"
IUSE=""
-DEPEND="virtual/libc
- virtual/x11
- >media-sound/xmms-1.2.4
+DEPEND=">media-sound/xmms-1.2.4
>=sys-apps/sed-4"
src_unpack() {
diff --git a/x11-plugins/wmusic/wmusic-1.5.0.ebuild b/x11-plugins/wmusic/wmusic-1.5.0.ebuild
index 9c8b2a564a17..84e425d7442a 100644
--- a/x11-plugins/wmusic/wmusic-1.5.0.ebuild
+++ b/x11-plugins/wmusic/wmusic-1.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmusic/wmusic-1.5.0.ebuild,v 1.5 2004/11/25 15:49:05 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmusic/wmusic-1.5.0.ebuild,v 1.6 2006/01/31 21:05:07 nelchael Exp $
DESCRIPTION="dockapp for xmms"
HOMEPAGE="http://home.jtan.com/~john/wmusic/"
@@ -9,9 +9,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 amd64 ~ppc ~sparc"
IUSE=""
-DEPEND="virtual/libc
- virtual/x11
- >media-sound/xmms-1.2.4
+DEPEND=">media-sound/xmms-1.2.4
>=sys-apps/sed-4"
src_unpack() {
diff --git a/x11-plugins/wmwave/ChangeLog b/x11-plugins/wmwave/ChangeLog
index e7e0d78b158d..25ab2c1efb03 100644
--- a/x11-plugins/wmwave/ChangeLog
+++ b/x11-plugins/wmwave/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmwave
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmwave/ChangeLog,v 1.6 2005/11/11 11:36:29 s4t4n Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmwave/ChangeLog,v 1.7 2006/01/31 21:06:41 nelchael Exp $
+
+ 31 Jan 2006; Krzysiek Pawlik <nelchael@gentoo.org> wmwave-0.4.ebuild:
+ Fixed DEPEND for modular X.
11 Nov 2005; Michele Noberasco <s4t4n@gentoo.org> wmwave-0.4.ebuild:
removed COPYING from dodoc.
diff --git a/x11-plugins/wmwave/wmwave-0.4.ebuild b/x11-plugins/wmwave/wmwave-0.4.ebuild
index 8f6ef501b697..03f37610354d 100644
--- a/x11-plugins/wmwave/wmwave-0.4.ebuild
+++ b/x11-plugins/wmwave/wmwave-0.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmwave/wmwave-0.4.ebuild,v 1.7 2005/11/11 11:36:29 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmwave/wmwave-0.4.ebuild,v 1.8 2006/01/31 21:06:41 nelchael Exp $
IUSE=""
S="${WORKDIR}/wmwave"
@@ -9,9 +9,16 @@ DESCRIPTION="wmwave is a dockapp that displays quality, link, level and noise of
SRC_URI="mirror://sourceforge/wmwave/${PN}-0-4.tgz"
HOMEPAGE="http://wmwave.sourceforge.net/"
LICENSE="GPL-2"
-DEPEND="virtual/x11"
SLOT="0"
+RDEPEND="|| ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm )
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( x11-proto/xextproto virtual/x11 )"
+
src_compile() {
emake FLAGS="${CFLAGS}" || die "Compilation failed"
}