summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/fxscintilla/ChangeLog9
-rw-r--r--x11-libs/fxscintilla/fxscintilla-2.28.0.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/x11-libs/fxscintilla/ChangeLog b/x11-libs/fxscintilla/ChangeLog
index fd9651d5ae73..83db19ccde96 100644
--- a/x11-libs/fxscintilla/ChangeLog
+++ b/x11-libs/fxscintilla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/fxscintilla
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/ChangeLog,v 1.49 2010/06/25 17:04:23 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/ChangeLog,v 1.50 2012/03/01 22:48:48 mabi Exp $
+
+*fxscintilla-2.28.0 (01 Mar 2012)
+
+ 01 Mar 2012; Matti Bickel <mabi@gentoo.org> +fxscintilla-2.28.0.ebuild:
+ version bump (bug #403089)
25 Jun 2010; Samuli Suominen <ssuominen@gentoo.org>
-files/1.62-fox-SLOT.patch, -fxscintilla-1.71-r1.ebuild,
diff --git a/x11-libs/fxscintilla/fxscintilla-2.28.0.ebuild b/x11-libs/fxscintilla/fxscintilla-2.28.0.ebuild
new file mode 100644
index 000000000000..590e37bb8fa3
--- /dev/null
+++ b/x11-libs/fxscintilla/fxscintilla-2.28.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/fxscintilla-2.28.0.ebuild,v 1.1 2012/03/01 22:48:48 mabi Exp $
+
+EAPI=4
+
+inherit autotools eutils multilib
+
+DESCRIPTION="A free source code editing component for the FOX-Toolkit"
+HOMEPAGE="http://www.nongnu.org/fxscintilla/"
+SRC_URI="http://savannah.nongnu.org/download/fxscintilla/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="|| ( x11-libs/fox:1.6 x11-libs/fox:1.7 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # fox-1.7.32 installs fox17.pc, the fox module is used by fox-1.6
+ if has_version "x11-libs/fox:1.7" ; then
+ sed -i -e "s/fox >= 1.7/fox17 >= 1.7/" "${S}/configure.in"
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf --libdir=/usr/$(get_libdir) --enable-shared
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ dodoc README
+ if use doc ; then
+ dodoc scintilla/doc/Lexer.txt
+ dohtml scintilla/doc/*
+ fi
+}
+
+pkg_postinst() {
+ elog "FXScintilla is now built only against the highest available"
+ elog "FOX-version you have installed."
+}