summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/xvba-video')
-rw-r--r--x11-libs/xvba-video/ChangeLog8
-rw-r--r--x11-libs/xvba-video/xvba-video-0.8.0-r1.ebuild12
-rw-r--r--x11-libs/xvba-video/xvba-video-9999.ebuild12
3 files changed, 24 insertions, 8 deletions
diff --git a/x11-libs/xvba-video/ChangeLog b/x11-libs/xvba-video/ChangeLog
index 2546c5dec5f2..cb3d6f1d59e1 100644
--- a/x11-libs/xvba-video/ChangeLog
+++ b/x11-libs/xvba-video/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/xvba-video
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xvba-video/ChangeLog,v 1.11 2012/12/26 11:33:31 ulm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xvba-video/ChangeLog,v 1.12 2013/02/04 18:58:56 scarabeus Exp $
+
+ 04 Feb 2013; Tomáš Chvátal <scarabeus@gentoo.org> xvba-video-0.8.0-r1.ebuild,
+ xvba-video-9999.ebuild:
+ Fix bug#453036 by using python-any-r1 eclass.
26 Dec 2012; Ulrich Müller <ulm@gentoo.org> xvba-video-0.8.0.ebuild,
xvba-video-0.8.0-r1.ebuild, xvba-video-9999.ebuild:
diff --git a/x11-libs/xvba-video/xvba-video-0.8.0-r1.ebuild b/x11-libs/xvba-video/xvba-video-0.8.0-r1.ebuild
index 4ba0c80e3af5..19810405b14d 100644
--- a/x11-libs/xvba-video/xvba-video-0.8.0-r1.ebuild
+++ b/x11-libs/xvba-video/xvba-video-0.8.0-r1.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xvba-video/xvba-video-0.8.0-r1.ebuild,v 1.3 2012/12/26 11:33:31 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xvba-video/xvba-video-0.8.0-r1.ebuild,v 1.4 2013/02/04 18:58:56 scarabeus Exp $
EAPI=5
EGIT_REPO_URI="git://anongit.freedesktop.org/vaapi/xvba-driver"
[[ ${PV} = 9999 ]] && inherit git-2
-inherit eutils autotools
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+inherit eutils autotools python-any-r1
DESCRIPTION="XVBA Backend for Video Acceleration (VA) API"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
@@ -27,12 +28,17 @@ RDEPEND="
x11-drivers/ati-drivers
"
DEPEND="${DEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig"
DOCS=( NEWS README AUTHORS )
S="${WORKDIR}/xvba-driver-${PV}"
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
src_prepare() {
eautoreconf
}
diff --git a/x11-libs/xvba-video/xvba-video-9999.ebuild b/x11-libs/xvba-video/xvba-video-9999.ebuild
index 5ca0b7bb68a7..de0fbc637010 100644
--- a/x11-libs/xvba-video/xvba-video-9999.ebuild
+++ b/x11-libs/xvba-video/xvba-video-9999.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xvba-video/xvba-video-9999.ebuild,v 1.3 2012/12/26 11:33:31 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xvba-video/xvba-video-9999.ebuild,v 1.4 2013/02/04 18:58:56 scarabeus Exp $
EAPI=5
EGIT_REPO_URI="git://anongit.freedesktop.org/vaapi/xvba-driver"
[[ ${PV} = 9999 ]] && inherit git-2
-inherit eutils autotools
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+inherit eutils autotools python-any-r1
DESCRIPTION="XVBA Backend for Video Acceleration (VA) API"
HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
@@ -26,10 +27,15 @@ RDEPEND="
x11-drivers/ati-drivers
"
DEPEND="${DEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig"
DOCS=( NEWS README AUTHORS )
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
src_prepare() {
eautoreconf
}