summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/qupzilla')
-rw-r--r--www-client/qupzilla/ChangeLog7
-rw-r--r--www-client/qupzilla/qupzilla-1.2.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/www-client/qupzilla/ChangeLog b/www-client/qupzilla/ChangeLog
index 8992ffe6ab6d..04cee88e72ac 100644
--- a/www-client/qupzilla/ChangeLog
+++ b/www-client/qupzilla/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/qupzilla
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/qupzilla/ChangeLog,v 1.2 2012/04/04 14:38:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/qupzilla/ChangeLog,v 1.3 2012/04/12 10:41:57 pesa Exp $
+
+*qupzilla-1.2.0 (12 Apr 2012)
+
+ 12 Apr 2012; Davide Pesavento <pesa@gentoo.org> +qupzilla-1.2.0.ebuild:
+ Version bump.
04 Apr 2012; Agostino Sarubbo <ago@gentoo.org> qupzilla-1.1.8.ebuild:
Add ~x86
diff --git a/www-client/qupzilla/qupzilla-1.2.0.ebuild b/www-client/qupzilla/qupzilla-1.2.0.ebuild
new file mode 100644
index 000000000000..14afdbf9366e
--- /dev/null
+++ b/www-client/qupzilla/qupzilla-1.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/qupzilla/qupzilla-1.2.0.ebuild,v 1.1 2012/04/12 10:41:57 pesa Exp $
+
+EAPI=4
+
+inherit qt4-r2 vcs-snapshot
+
+DESCRIPTION="Qt WebKit web browser"
+HOMEPAGE="http://www.qupzilla.com/"
+SRC_URI="https://github.com/nowrep/QupZilla/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug kde"
+
+DEPEND="
+ >=x11-libs/qt-core-4.7:4
+ >=x11-libs/qt-dbus-4.7:4
+ >=x11-libs/qt-gui-4.7:4
+ >=x11-libs/qt-script-4.7:4
+ >=x11-libs/qt-sql-4.7:4
+ >=x11-libs/qt-webkit-4.7:4
+"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS FAQ TODO"
+
+src_configure() {
+ export QUPZILLA_PREFIX="${EPREFIX}/usr/"
+
+ if use kde; then
+ KDE=true eqmake4
+ else
+ eqmake4
+ fi
+}
+
+# TODO: translation handling