summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/tikiwiki/ChangeLog9
-rw-r--r--www-apps/tikiwiki/files/digest-tikiwiki-1.9.93
-rw-r--r--www-apps/tikiwiki/tikiwiki-1.9.9.ebuild72
3 files changed, 82 insertions, 2 deletions
diff --git a/www-apps/tikiwiki/ChangeLog b/www-apps/tikiwiki/ChangeLog
index f65638db24a7..80db981d8156 100644
--- a/www-apps/tikiwiki/ChangeLog
+++ b/www-apps/tikiwiki/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/tikiwiki
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.51 2007/10/31 04:51:20 wrobel Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.52 2008/01/17 09:15:59 wrobel Exp $
+
+*tikiwiki-1.9.9 (17 Jan 2008)
+
+ 17 Jan 2008; Gunnar Wrobel <wrobel@gentoo.org> +tikiwiki-1.9.9.ebuild:
+ Added tikiwiki-1.9.9 in response to sec issue #203265)
31 Oct 2007; <wrobel@gentoo.org> -tikiwiki-1.9.8.1.ebuild,
-tikiwiki-1.9.8.2.ebuild:
diff --git a/www-apps/tikiwiki/files/digest-tikiwiki-1.9.9 b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.9
new file mode 100644
index 000000000000..f40da00dfad6
--- /dev/null
+++ b/www-apps/tikiwiki/files/digest-tikiwiki-1.9.9
@@ -0,0 +1,3 @@
+MD5 eff4c14810b3da79c5122475f6f419df tikiwiki-1.9.9.tar.bz2 6645685
+RMD160 7cb44191a1d19bfe7a3fd1e6c21b0318039f5a08 tikiwiki-1.9.9.tar.bz2 6645685
+SHA256 cd3c3489c4038f065b343296fc37b076812dfe9d9909a20de5049aff15e3a434 tikiwiki-1.9.9.tar.bz2 6645685
diff --git a/www-apps/tikiwiki/tikiwiki-1.9.9.ebuild b/www-apps/tikiwiki/tikiwiki-1.9.9.ebuild
new file mode 100644
index 000000000000..2e2ff05b5ced
--- /dev/null
+++ b/www-apps/tikiwiki/tikiwiki-1.9.9.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/tikiwiki-1.9.9.ebuild,v 1.1 2008/01/17 09:15:59 wrobel Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Full-featured Web Content Management System using PHP and Smarty Templates"
+HOMEPAGE="http://tikiwiki.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+IUSE="mysql postgres graphviz"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="virtual/httpd-cgi
+ graphviz? ( media-gfx/graphviz )
+"
+
+need_php_httpd
+
+pkg_setup () {
+ webapp_pkg_setup
+ use mysql && require_php_with_use mysql
+ use postgres && require_php_with_use postgres
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local DIR
+ local DIRENTRY
+ local DIRS="backups db dump files img/trackers img/wiki
+ img/wiki_up modules/cache temp
+ templates_c templates styles maps whelp mods
+ lib/Galaxia/processes"
+
+ # Ensure that directories exist, some don't.
+ # (part of setup.sh)
+ for DIR in ${DIRS}; do
+ mkdir -p ${DIR}
+ done
+
+ # Remove the execute permission from the setup.sh script
+ # and rename it. Its actions have been incorporated here.
+ chmod a-x setup.sh
+ mv setup.sh setup.sh.done
+
+ # Install the minimal doc (points to web page)
+ #
+ dodoc doc/readme.txt doc/htaccess doc/htaccess.readme INSTALL README
+
+ # The bulk goes into htdocs
+ # but don't copy INSTALL and README
+ cp -pPR [[:lower:]]* "${D}"/"${MY_HTDOCSDIR}"
+
+ # Recursively set server ownership to allow server to write
+ # This is the rough equivalent of the setup.sh script
+ # provided in the distribution.
+ # Note: Cannot use xargs or find -exec here because
+ # these don't work with shell functions.
+ #
+ webapp_serverowned "${MY_HTDOCSDIR}"
+ for DIR in ${DIRS}; do
+ find ${DIR} | while read DIRENTRY; do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${DIRENTRY}
+ done
+ done
+ webapp_serverowned "${MY_HTDOCSDIR}"/tiki-install.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}