summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/atop/atop-1.17.ebuild')
-rw-r--r--sys-process/atop/atop-1.17.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-process/atop/atop-1.17.ebuild b/sys-process/atop/atop-1.17.ebuild
new file mode 100644
index 000000000000..7e68a513e8de
--- /dev/null
+++ b/sys-process/atop/atop-1.17.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/atop/atop-1.17.ebuild,v 1.1 2006/12/02 23:28:01 vapier Exp $
+
+DESCRIPTION="Resource-specific view of processes"
+HOMEPAGE="http://www.atcomputing.nl/Tools/atop"
+SRC_URI="http://www.atconsultancy.nl/atop/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-process/acct"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^CFLAGS/s: = -O : += :' \
+ -e '/^LDFLAGS/s: = : += :' \
+ Makefile
+ mv "${S}"/atop.init "${S}"/atop.init.old
+ cp "${FILESDIR}"/atop.rc "${S}"/atop.init
+ chmod a+rx atop.init
+}
+
+src_install() {
+ emake DESTDIR="${D}" INIPATH=/etc/init.d install || die
+ dodoc README
+}