summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/spindown/ChangeLog8
-rw-r--r--sys-block/spindown/files/spindown-0.4.0-CFLAGS-LDFLAGS.patch55
-rw-r--r--sys-block/spindown/spindown-0.4.0-r4.ebuild46
3 files changed, 108 insertions, 1 deletions
diff --git a/sys-block/spindown/ChangeLog b/sys-block/spindown/ChangeLog
index a869f17fe2dd..2186e3f193c8 100644
--- a/sys-block/spindown/ChangeLog
+++ b/sys-block/spindown/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-block/spindown
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/spindown/ChangeLog,v 1.7 2012/01/01 01:04:34 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/spindown/ChangeLog,v 1.8 2012/03/11 11:38:51 wschlich Exp $
+
+*spindown-0.4.0-r4 (11 Mar 2012)
+
+ 11 Mar 2012; Wolfram Schlich <wschlich@gentoo.org> +spindown-0.4.0-r4.ebuild,
+ +files/spindown-0.4.0-CFLAGS-LDFLAGS.patch:
+ respect LDFLAGS wrt bug #339110
*spindown-0.4.0-r3 (01 Jan 2012)
*spindown-0.4.0-r2 (01 Jan 2012)
diff --git a/sys-block/spindown/files/spindown-0.4.0-CFLAGS-LDFLAGS.patch b/sys-block/spindown/files/spindown-0.4.0-CFLAGS-LDFLAGS.patch
new file mode 100644
index 000000000000..9101fbadb59c
--- /dev/null
+++ b/sys-block/spindown/files/spindown-0.4.0-CFLAGS-LDFLAGS.patch
@@ -0,0 +1,55 @@
+diff -urN spindown-0.4.0.orig/Makefile spindown-0.4.0/Makefile
+--- spindown-0.4.0.orig/Makefile 2009-04-18 18:32:59.000000000 +0200
++++ spindown-0.4.0/Makefile 2012-03-11 00:22:07.684197769 +0100
+@@ -4,7 +4,8 @@
+ OBJS = main.o diskset.o disk.o spindown.o iniparser.o dictionary.o log.o spindownd.o\
+ exceptions.o
+ CC = g++
+-CFLAGS =-O1
++CFLAGS +=
++LDFLAGS +=
+ SRC = src/
+ INPARSER = $(SRC)ininiparser3.0b/
+ SRCDIR = spindown-$(VERSION)
+@@ -60,31 +61,31 @@
+ rm -d -r -f $(SRCDIR)
+
+ spindownd: $(OBJS)
+- g++ $(CFLAGS) -o spindownd $(OBJS)
++ g++ $(CFLAGS) $(LDFLAGS) -o spindownd $(OBJS)
+
+ main.o: $(SRC)main.cpp $(SRC)general.h
+- g++ $(CFLAGS) -c $(SRC)main.cpp
++ g++ $(CFLAGS) $(LDFLAGS) -c $(SRC)main.cpp
+
+ diskset.o: $(SRC)diskset.cpp $(SRC)diskset.h $(SRC)general.h
+- g++ $(CFLAGS) -c $(SRC)diskset.cpp
++ g++ $(CFLAGS) $(LDFLAGS) -c $(SRC)diskset.cpp
+
+ disk.o: $(SRC)disk.cpp $(SRC)disk.h $(SRC)general.h
+- g++ $(CFLAGS) -c $(SRC)disk.cpp
++ g++ $(CFLAGS) $(LDFLAGS) -c $(SRC)disk.cpp
+
+ spindown.o: $(SRC)spindown.cpp $(SRC)spindown.h $(SRC)general.h
+- g++ $(CFLAGS) -c $(SRC)spindown.cpp
++ g++ $(CFLAGS) $(LDFLAGS) -c $(SRC)spindown.cpp
+
+ spindownd.o: $(SRC)spindownd.cpp $(SRC)spindownd.h $(SRC)general.h
+- g++ $(CFLAGS) -c $(SRC)spindownd.cpp
++ g++ $(CFLAGS) $(LDFLAGS) -c $(SRC)spindownd.cpp
+
+ log.o: $(SRC)log.cpp $(SRC)log.h $(SRC)general.h
+- g++ $(CFLAGS) -c $(SRC)log.cpp
++ g++ $(CFLAGS) $(LDFLAGS) -c $(SRC)log.cpp
+
+ exceptions.o: $(SRC)exceptions.cpp $(SRC)exceptions.h $(SRC)general.h
+- g++ $(CFLAGS) -c $(SRC)exceptions.cpp
++ g++ $(CFLAGS) $(LDFLAGS) -c $(SRC)exceptions.cpp
+
+ iniparser.o: $(INPARSER)iniparser.c
+- g++ $(CFLAGS) -c $(INPARSER)iniparser.c
++ g++ $(CFLAGS) $(LDFLAGS) -c $(INPARSER)iniparser.c
+
+ dictionary.o: $(INPARSER)dictionary.c
+- g++ $(CFLAGS) -c $(INPARSER)dictionary.c
++ g++ $(CFLAGS) $(LDFLAGS) -c $(INPARSER)dictionary.c
diff --git a/sys-block/spindown/spindown-0.4.0-r4.ebuild b/sys-block/spindown/spindown-0.4.0-r4.ebuild
new file mode 100644
index 000000000000..95007a3c9dc5
--- /dev/null
+++ b/sys-block/spindown/spindown-0.4.0-r4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/spindown/spindown-0.4.0-r4.ebuild,v 1.1 2012/03/11 11:38:51 wschlich Exp $
+
+inherit eutils
+
+DESCRIPTION="Spindown is a daemon that can spin down idle disks"
+HOMEPAGE="http://code.google.com/p/spindown"
+SRC_URI="http://spindown.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ sys-apps/sg3_utils"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-CFLAGS-LDFLAGS.patch
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ insinto /etc
+ newins spindown.conf.example spindown.conf
+ newinitd "${FILESDIR}"/spindownd.initd-r1 spindownd
+ newconfd "${FILESDIR}"/spindownd.confd-r1 spindownd
+ dosbin spindownd
+ dodoc CHANGELOG README TODO spindown.conf.example
+}
+
+pkg_postinst() {
+ elog "Before starting spindownd the first time"
+ elog "you should modify /etc/spindown.conf"
+ elog
+ elog "To start spindownd by default"
+ elog "you should add it to the default runlevel:"
+ elog " rc-update add spindownd default"
+}