summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hwsetup')
-rw-r--r--sys-apps/hwsetup/ChangeLog6
-rw-r--r--sys-apps/hwsetup/files/1.2-strip.patch11
-rw-r--r--sys-apps/hwsetup/hwsetup-1.2-r1.ebuild5
3 files changed, 19 insertions, 3 deletions
diff --git a/sys-apps/hwsetup/ChangeLog b/sys-apps/hwsetup/ChangeLog
index 4ba1f2e3d671..b6453858996f 100644
--- a/sys-apps/hwsetup/ChangeLog
+++ b/sys-apps/hwsetup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/hwsetup
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/ChangeLog,v 1.58 2008/10/14 09:30:11 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/ChangeLog,v 1.59 2008/12/22 05:36:05 jer Exp $
+
+ 22 Dec 2008; Jeroen Roovers <jer@gentoo.org> +files/1.2-strip.patch,
+ hwsetup-1.2-r1.ebuild:
+ Do not let the Makefile append LDFLAGS (bug #252059).
14 Oct 2008; Robin H. Johnson <robbat2@gentoo.org> hwsetup-1.2-r1.ebuild:
Bug #226923, fix append-ldflags usage.
diff --git a/sys-apps/hwsetup/files/1.2-strip.patch b/sys-apps/hwsetup/files/1.2-strip.patch
new file mode 100644
index 000000000000..f1b853760096
--- /dev/null
+++ b/sys-apps/hwsetup/files/1.2-strip.patch
@@ -0,0 +1,11 @@
+--- hwsetup-1.2/Makefile.orig 2005-05-07 15:20:44.000000000 +0200
++++ hwsetup-1.2/Makefile 2008-12-22 06:27:41.000000000 +0100
+@@ -3,7 +3,7 @@
+ # define BLACKLIST to avoid loading potentially dangerous modules
+ CFLAGS=-DBLACKLIST -Wall -fPIC
+ OPT=-O2
+-LDFLAGS=-s
++#LDFLAGS=-s
+ LIBS=-lkudzu -lpci
+ CC=gcc
+
diff --git a/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild b/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild
index 07278a5109a9..d422f9ed2a46 100644
--- a/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild
+++ b/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild,v 1.3 2008/10/14 09:30:11 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild,v 1.4 2008/12/22 05:36:05 jer Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -33,7 +33,8 @@ src_unpack() {
epatch \
"${FILESDIR}"/${MY_PV}-dyn_blacklist.patch \
"${FILESDIR}"/${PV}-3-fastprobe.patch \
- "${FILESDIR}"/${MY_PV}-gentoo.patch
+ "${FILESDIR}"/${MY_PV}-gentoo.patch \
+ "${FILESDIR}"/${PV}-strip.patch
}
src_compile() {