summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/agda-stdlib/ChangeLog10
-rw-r--r--sci-mathematics/agda-stdlib/agda-stdlib-0.6.ebuild42
-rw-r--r--sci-mathematics/agda-stdlib/files/50agda-stdlib-gentoo.el1
-rw-r--r--sci-mathematics/agda-stdlib/metadata.xml9
4 files changed, 62 insertions, 0 deletions
diff --git a/sci-mathematics/agda-stdlib/ChangeLog b/sci-mathematics/agda-stdlib/ChangeLog
new file mode 100644
index 000000000000..1eaf98e412f9
--- /dev/null
+++ b/sci-mathematics/agda-stdlib/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-mathematics/agda-stdlib
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda-stdlib/ChangeLog,v 1.1 2012/03/25 14:02:15 gienah Exp $
+
+*agda-stdlib-0.6 (25 Mar 2012)
+
+ 25 Mar 2012; Mark Wright <gienah@gentoo.org> +agda-stdlib-0.6.ebuild,
+ +files/50agda-stdlib-gentoo.el, +metadata.xml:
+ Thanks to tomprince for adding support for agda-stdlib.
+
diff --git a/sci-mathematics/agda-stdlib/agda-stdlib-0.6.ebuild b/sci-mathematics/agda-stdlib/agda-stdlib-0.6.ebuild
new file mode 100644
index 000000000000..f5feecd9921a
--- /dev/null
+++ b/sci-mathematics/agda-stdlib/agda-stdlib-0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda-stdlib/agda-stdlib-0.6.ebuild,v 1.1 2012/03/25 14:02:15 gienah Exp $
+
+EAPI=4
+
+DESCRIPTION="Agda standard library"
+HOMEPAGE="http://wiki.portal.chalmers.se/agda/"
+SRC_URI="http://www.cse.chalmers.se/~nad/software/lib-${PV}.tar.gz -> ${P}.tar.gz"
+
+inherit elisp-common
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="profile"
+
+DEPEND="=sci-mathematics/agda-executable-2.3.0*"
+RDEPEND="=sci-mathematics/agda-2.3.0*[profile?]"
+
+SITEFILE="50${PN}-gentoo.el"
+
+S="${WORKDIR}/lib-${PV}"
+
+src_compile() {
+ local prof
+ use profile && prof="--ghc-flag=-prof"
+ agda +RTS -K1G -RTS ${prof} \
+ -i "${S}" -i "${S}"/src "${S}"/Everything.agda || die
+ agda --html -i "${S}" -i "${S}"/src "${S}"/README.agda || die
+}
+
+src_test() {
+ agda -i "${S}" -i "${S}"/src README.agda || die
+}
+
+src_install() {
+ insinto usr/share/agda-stdlib
+ doins -r src/*
+ dodoc -r html/*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+}
diff --git a/sci-mathematics/agda-stdlib/files/50agda-stdlib-gentoo.el b/sci-mathematics/agda-stdlib/files/50agda-stdlib-gentoo.el
new file mode 100644
index 000000000000..62264a4451a0
--- /dev/null
+++ b/sci-mathematics/agda-stdlib/files/50agda-stdlib-gentoo.el
@@ -0,0 +1 @@
+(setq agda2-include-dirs '("." "/usr/share/agda-stdlib"))
diff --git a/sci-mathematics/agda-stdlib/metadata.xml b/sci-mathematics/agda-stdlib/metadata.xml
new file mode 100644
index 000000000000..931d619e5994
--- /dev/null
+++ b/sci-mathematics/agda-stdlib/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+ <herd>haskell</herd>
+<longdescription lang="en">
+ Agda standard library.
+</longdescription>
+</pkgmetadata>