summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/python-wifi/python-wifi-0.5.0.ebuild')
-rw-r--r--net-wireless/python-wifi/python-wifi-0.5.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-wireless/python-wifi/python-wifi-0.5.0.ebuild b/net-wireless/python-wifi/python-wifi-0.5.0.ebuild
new file mode 100644
index 000000000000..de7359f8c7fb
--- /dev/null
+++ b/net-wireless/python-wifi/python-wifi-0.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/python-wifi/python-wifi-0.5.0.ebuild,v 1.1 2011/03/06 10:31:06 jlec Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3*"
+
+inherit distutils
+
+DESCRIPTION="Provides r/w access to a wireless network card's capabilities using the Linux Wireless Extensions"
+HOMEPAGE="http://pypi.python.org/pypi/python-wifi https://developer.berlios.de/projects/pythonwifi"
+SRC_URI="mirror://berlios/${PN/-}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2.1 examples? ( GPL-2 )"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools"
+
+DOCS="docs/AUTHORS docs/BUGS docs/DEVEL.txt docs/TODO"
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/${P}/
+ doins -r examples || die "no examples"
+ fi
+}