summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/sic/ChangeLog9
-rw-r--r--net-irc/sic/sic-1.2.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/net-irc/sic/ChangeLog b/net-irc/sic/ChangeLog
index d3f0e641faf2..70eeade1b291 100644
--- a/net-irc/sic/ChangeLog
+++ b/net-irc/sic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/sic
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/sic/ChangeLog,v 1.9 2012/08/04 19:07:14 johu Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/sic/ChangeLog,v 1.10 2014/01/04 05:50:06 radhermit Exp $
+
+*sic-1.2 (04 Jan 2014)
+
+ 04 Jan 2014; Tim Harder <radhermit@gentoo.org> +sic-1.2.ebuild:
+ Version bump.
04 Aug 2012; Johannes Huber <johu@gentoo.org> sic-1.1.ebuild:
Stable for x86, wrt bug #419253
diff --git a/net-irc/sic/sic-1.2.ebuild b/net-irc/sic/sic-1.2.ebuild
new file mode 100644
index 000000000000..b31c5bc1e3ed
--- /dev/null
+++ b/net-irc/sic/sic-1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/sic/sic-1.2.ebuild,v 1.1 2014/01/04 05:50:07 radhermit Exp $
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="An extremly simple IRC client"
+HOMEPAGE="http://tools.suckless.org/sic"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e "s/CFLAGS =/CFLAGS +=/g" \
+ -e "s/-Os//" \
+ -e "s/LDFLAGS = -s/LDFLAGS +=/" \
+ -e "/^LIBS =/d" \
+ -e "s/= cc/= $(tc-getCC)/g" \
+ config.mk || die "sed failed"
+
+ # enable verbose build
+ sed -i 's/@${CC}/${CC}/' Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}