summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/netwox/ChangeLog8
-rw-r--r--net-analyzer/netwox/files/digest-netwox-5.6.01
-rw-r--r--net-analyzer/netwox/netwox-5.6.0.ebuild37
3 files changed, 46 insertions, 0 deletions
diff --git a/net-analyzer/netwox/ChangeLog b/net-analyzer/netwox/ChangeLog
new file mode 100644
index 000000000000..e063477e7b99
--- /dev/null
+++ b/net-analyzer/netwox/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-analyzer/netwox
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwox/ChangeLog,v 1.1 2003/12/26 02:04:06 vapier Exp $
+
+*netwox-5.6.0 (25 Dec 2003)
+
+ 25 Dec 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump + cleanup #35158.
diff --git a/net-analyzer/netwox/files/digest-netwox-5.6.0 b/net-analyzer/netwox/files/digest-netwox-5.6.0
new file mode 100644
index 000000000000..42d208fc8a63
--- /dev/null
+++ b/net-analyzer/netwox/files/digest-netwox-5.6.0
@@ -0,0 +1 @@
+MD5 90386348073dd21731cbd701e9588170 netwox-5.6.0-src.tgz 240651
diff --git a/net-analyzer/netwox/netwox-5.6.0.ebuild b/net-analyzer/netwox/netwox-5.6.0.ebuild
new file mode 100644
index 000000000000..6a594b3806ce
--- /dev/null
+++ b/net-analyzer/netwox/netwox-5.6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwox/netwox-5.6.0.ebuild,v 1.1 2003/12/26 02:04:06 vapier Exp $
+
+DESCRIPTION="Toolbox of over 400 utilities for testing Ethernet/IP networks"
+HOMEPAGE="http://www.laurentconstantin.com/en/netw/netwox/"
+SRC_URI="http://www.laurentconstantin.com/common/netw/${PN}/download/v${PV/.*}/${P}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc"
+
+DEPEND="=net-libs/netwib-${PV}*"
+
+S=${WORKDIR}/${P}-src
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+
+ sed -i \
+ -e 's:/usr/local:/usr:g' \
+ -e "s:-O2:${CFLAGS}:" \
+ genemake config.dat
+ ./genemake || die "problem creating Makefile"
+}
+
+src_compile() {
+ cd src
+ emake -j1 || die "compile problem"
+}
+
+src_install() {
+ dodoc README.TXT doc/*.txt
+ cd src
+ make install DESTDIR=${D} || die
+}