summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/traverso/traverso-9999.ebuild')
-rw-r--r--media-sound/traverso/traverso-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/media-sound/traverso/traverso-9999.ebuild b/media-sound/traverso/traverso-9999.ebuild
index 72207615c96f..54a89d335492 100644
--- a/media-sound/traverso/traverso-9999.ebuild
+++ b/media-sound/traverso/traverso-9999.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/traverso/traverso-9999.ebuild,v 1.3 2008/04/20 17:42:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/traverso/traverso-9999.ebuild,v 1.4 2008/04/20 17:58:41 aballier Exp $
+
+EAPI=1
inherit eutils qt4 cmake-utils cvs
@@ -13,7 +15,8 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS=""
-RDEPEND="$(qt4_min_version 4.3.1)
+RDEPEND="|| ( ( x11-libs/qt-core x11-libs/qt-gui opengl? ( x11-libs/qt-opengl ) )
+ >=x11-libs/qt-4.3.1:4 )
alsa? ( >=media-libs/alsa-lib-1.0.0 )
jack? ( >=media-sound/jack-audio-connection-kit-0.100 )
>=dev-libs/glib-2.8
@@ -30,7 +33,7 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
pkg_setup() {
- if use opengl && ! built_with_use =x11-libs/qt-4* opengl; then
+ if use opengl && ! has_version x11-libs/qt-opengl && ! built_with_use =x11-libs/qt-4* opengl; then
eerror "You need to build qt4 with opengl support to have it in ${PN}"
die "Enabling opengl for traverso requires qt4 to be built with opengl support"
fi
@@ -52,7 +55,6 @@ src_compile() {
cmake-utils_src_compile
}
-
src_install() {
cmake-utils_src_install
dodoc AUTHORS ChangeLog README resources/help.text