summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/KochMorse/ChangeLog8
-rw-r--r--media-radio/KochMorse/KochMorse-0.99.6.ebuild19
2 files changed, 18 insertions, 9 deletions
diff --git a/media-radio/KochMorse/ChangeLog b/media-radio/KochMorse/ChangeLog
index db8dac967b15..7dc87425a25b 100644
--- a/media-radio/KochMorse/ChangeLog
+++ b/media-radio/KochMorse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-radio/KochMorse
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/KochMorse/ChangeLog,v 1.3 2010/10/05 20:48:22 maekke Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/KochMorse/ChangeLog,v 1.4 2011/03/11 18:39:07 arfrever Exp $
+
+ 11 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ KochMorse-0.99.6.ebuild:
+ Use Python 2.
05 Oct 2010; Markus Meier <maekke@gentoo.org> KochMorse-0.99.6.ebuild:
x86 stable, bug #335430
diff --git a/media-radio/KochMorse/KochMorse-0.99.6.ebuild b/media-radio/KochMorse/KochMorse-0.99.6.ebuild
index 3cb6d35ac6de..9b6d9f449bcf 100644
--- a/media-radio/KochMorse/KochMorse-0.99.6.ebuild
+++ b/media-radio/KochMorse/KochMorse-0.99.6.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/KochMorse/KochMorse-0.99.6.ebuild,v 1.3 2010/10/05 20:48:22 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/KochMorse/KochMorse-0.99.6.ebuild,v 1.4 2011/03/11 18:39:07 arfrever Exp $
-EAPI=2
+EAPI="3"
+PYTHON_DEPEND="2"
-PYTHON_DEPEND="*"
-
-inherit distutils python
+inherit distutils
DESCRIPTION="Morse-tutor for Linux using the Koch-method"
HOMEPAGE="http://KochMorse.googlecode.com/"
@@ -17,5 +16,11 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-RDEPEND="dev-python/pyalsaaudio
+DEPEND="dev-python/pyalsaaudio
dev-python/pygtk"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}