summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/krecipes/ChangeLog8
-rw-r--r--kde-misc/krecipes/krecipes-2.0_alpha4.ebuild32
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-misc/krecipes/ChangeLog b/kde-misc/krecipes/ChangeLog
index 3f4c38d0339d..bfd019d5f55f 100644
--- a/kde-misc/krecipes/ChangeLog
+++ b/kde-misc/krecipes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/krecipes
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/krecipes/ChangeLog,v 1.32 2009/10/24 09:33:25 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/krecipes/ChangeLog,v 1.33 2009/10/28 00:39:39 ssuominen Exp $
+
+*krecipes-2.0_alpha4 (28 Oct 2009)
+
+ 28 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +krecipes-2.0_alpha4.ebuild:
+ Version bump.
*krecipes-2.0_alpha3 (24 Oct 2009)
diff --git a/kde-misc/krecipes/krecipes-2.0_alpha4.ebuild b/kde-misc/krecipes/krecipes-2.0_alpha4.ebuild
new file mode 100644
index 000000000000..f2c9a813d2ae
--- /dev/null
+++ b/kde-misc/krecipes/krecipes-2.0_alpha4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/krecipes/krecipes-2.0_alpha4.ebuild,v 1.1 2009/10/28 00:39:39 ssuominen Exp $
+
+EAPI=2
+KDE_MINIMAL=4.2
+KDE_LINGUAS="cs da de el en_GB es et fr ga gl hi hne is it ja lt nb nds nl nn
+pl pt pt_BR ro sk sv tr uk zh_TW"
+KDE_DOC_DIRS="doc doc-translations/%lingua_${PN}"
+
+inherit kde4-base
+
+DESCRIPTION="A KDE4 recipe application"
+HOMEPAGE="http://krecipes.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P/_/-}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug +handbook"
+
+DEPEND=">=kde-base/kdelibs-${KDE_MINIMAL}[semantic-desktop]
+ !${CATEGORY}/${PN}:0"
+
+S=${WORKDIR}/${P/_/-}
+
+src_configure() {
+ # -DWITH_Soprano=OFF doesn't compile
+ mycmakeargs="${mycmakeargs}
+ -DWITH_Soprano=ON"
+ kde4-base_src_configure
+}