summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdenetwork')
-rw-r--r--kde-base/kdenetwork/kdenetwork-2.2.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/kde-base/kdenetwork/kdenetwork-2.2.1.ebuild b/kde-base/kdenetwork/kdenetwork-2.2.1.ebuild
new file mode 100644
index 000000000000..d0ff4a961faf
--- /dev/null
+++ b/kde-base/kdenetwork/kdenetwork-2.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Philippe Namias <pnamias@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-2.2.1.ebuild,v 1.1 2001/09/19 06:24:04 danarmak Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="KDE ${PV} - Network"
+SRC_PATH="kde/stable/${PV}/src/${P}.tar.bz2"
+SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
+ ftp://ftp.fh-heilbronn.de/pub/mirrors/$SRC_PATH
+ ftp://ftp.sourceforge.net/pub/mirrors/$SRC_PATH"
+
+HOMEPAGE="http://www.kde.org"
+
+DEPEND=">=kde-base/kdelibs-${PV}
+ objprelink? ( dev-util/objprelink )"
+
+RDEPEND=$DEPEND
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ unpack ${P}.tar.bz2
+
+}
+
+src_compile() {
+ . /etc/env.d/90{kde${PV},qt}
+ local myconf
+ if [ "`use qtmt`" ]
+ then
+ myconf="--enable-mt"
+ fi
+ if [ "`use mitshm`" ]
+ then
+ myconf="$myconf --enable-mitshm"
+ fi
+ if [ "`use objprelink`" ] ; then
+ myconf="$myconf --enable-objprelink"
+ fi
+ ./configure --host=${CHOST} \
+ --with-xinerama $myconf || die
+ make || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc AUTHORS COPYING README
+}