summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-mud')
-rw-r--r--games-mud/lyntin/ChangeLog9
-rw-r--r--games-mud/lyntin/lyntin-4.2-r1.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/games-mud/lyntin/ChangeLog b/games-mud/lyntin/ChangeLog
index d79f20c85a50..83f90c0edec4 100644
--- a/games-mud/lyntin/ChangeLog
+++ b/games-mud/lyntin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-mud/lyntin
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/lyntin/ChangeLog,v 1.16 2011/04/06 20:10:23 arfrever Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/lyntin/ChangeLog,v 1.17 2013/01/17 15:47:14 hasufell Exp $
+
+*lyntin-4.2-r1 (17 Jan 2013)
+
+ 17 Jan 2013; Julian Ospald <hasufell@gentoo.org> +lyntin-4.2-r1.ebuild:
+ migrate to distutils-r1
06 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
lyntin-4.2.ebuild:
diff --git a/games-mud/lyntin/lyntin-4.2-r1.ebuild b/games-mud/lyntin/lyntin-4.2-r1.ebuild
new file mode 100644
index 000000000000..f1cf55c10a70
--- /dev/null
+++ b/games-mud/lyntin/lyntin-4.2-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/lyntin/lyntin-4.2-r1.ebuild,v 1.1 2013/01/17 15:47:14 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+PYTHON_REQ_USE="tk?"
+
+inherit distutils-r1 games
+
+DESCRIPTION="tintin mud client clone implemented in Python"
+HOMEPAGE="http://lyntin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lyntin/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="tk"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+DOCS=( COMMANDS PKG-INFO HACKING README )
+
+python_install() {
+ distutils-r1_python_install --install-scripts="${GAMES_BINDIR}"
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if use tk ; then
+ elog "To start lyntin in GUI mode, create a config file"
+ elog "with this in it:"
+ elog
+ elog "[Lyntin]"
+ elog "ui: tk"
+ elog
+ elog "Then start lyntin like this:"
+ elog
+ elog "runlyntin -c /path/to/config_file\n"
+ fi
+}