summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/ggz-txt-client')
-rw-r--r--games-board/ggz-txt-client/ChangeLog6
-rw-r--r--games-board/ggz-txt-client/ggz-txt-client-0.0.13.ebuild12
2 files changed, 15 insertions, 3 deletions
diff --git a/games-board/ggz-txt-client/ChangeLog b/games-board/ggz-txt-client/ChangeLog
index 2e1e35866d82..aacd5cc8647f 100644
--- a/games-board/ggz-txt-client/ChangeLog
+++ b/games-board/ggz-txt-client/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/ggz-txt-client
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ggz-txt-client/ChangeLog,v 1.12 2006/10/06 22:39:45 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/ggz-txt-client/ChangeLog,v 1.13 2006/10/16 18:52:21 nyhm Exp $
+
+ 16 Oct 2006; Tristan Heaven <nyhm@gentoo.org>
+ ggz-txt-client-0.0.13.ebuild:
+ Don't clobber ggz.modules when installing
06 Oct 2006; Tristan Heaven <nyhm@gentoo.org>
ggz-txt-client-0.0.13.ebuild:
diff --git a/games-board/ggz-txt-client/ggz-txt-client-0.0.13.ebuild b/games-board/ggz-txt-client/ggz-txt-client-0.0.13.ebuild
index fac1c68c8f72..a50bebb6dc0d 100644
--- a/games-board/ggz-txt-client/ggz-txt-client-0.0.13.ebuild
+++ b/games-board/ggz-txt-client/ggz-txt-client-0.0.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ggz-txt-client/ggz-txt-client-0.0.13.ebuild,v 1.6 2006/10/06 22:39:45 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/ggz-txt-client/ggz-txt-client-0.0.13.ebuild,v 1.7 2006/10/16 18:52:21 nyhm Exp $
inherit games
@@ -13,6 +13,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-amd64 ppc x86"
IUSE=""
+RESTRICT="userpriv"
RDEPEND="~dev-games/ggz-client-libs-${PV}
sys-libs/ncurses
@@ -29,11 +30,18 @@ src_unpack() {
}
src_compile() {
- egamesconf --datadir=/usr/share || die
+ egamesconf \
+ --disable-debug \
+ --datadir=/usr/share \
+ || die
emake || die "emake failed"
}
src_install() {
+ if [[ -f "${ROOT}/${GAMES_SYSCONFDIR}"/ggz/ggz.modules ]] ; then
+ dodir "${GAMES_SYSCONFDIR}"/ggz
+ cp {"${ROOT}","${D}"}/"${GAMES_SYSCONFDIR}"/ggz/ggz.modules
+ fi
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS QuickStart.GGZ README* TODO
prepgamesdirs