summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gitg/ChangeLog9
-rw-r--r--dev-util/gitg/gitg-0.0.6.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/dev-util/gitg/ChangeLog b/dev-util/gitg/ChangeLog
index 1d869d326c9f..80a6b5f7c1cc 100644
--- a/dev-util/gitg/ChangeLog
+++ b/dev-util/gitg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/gitg
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gitg/ChangeLog,v 1.10 2009/12/07 11:24:57 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gitg/ChangeLog,v 1.11 2010/02/21 16:40:39 sping Exp $
+
+*gitg-0.0.6 (21 Feb 2010)
+
+ 21 Feb 2010; Sebastian Pipping <sping@gentoo.org> +gitg-0.0.6.ebuild:
+ Bump to 0.0.6
07 Dec 2009; Markus Meier <maekke@gentoo.org> gitg-0.0.5.ebuild:
amd64 stable, bug #288185
diff --git a/dev-util/gitg/gitg-0.0.6.ebuild b/dev-util/gitg/gitg-0.0.6.ebuild
new file mode 100644
index 000000000000..fedef9bc6226
--- /dev/null
+++ b/dev-util/gitg/gitg-0.0.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gitg/gitg-0.0.6.ebuild,v 1.1 2010/02/21 16:40:39 sping Exp $
+
+EAPI="2"
+
+inherit gnome2
+
+DESCRIPTION="git repository viewer for GNOME"
+HOMEPAGE="http://trac.novowork.com/gitg/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=x11-libs/gtk+-2.16
+ >=x11-libs/gtksourceview-2.8
+ >=gnome-base/gconf-2.10
+ dev-util/git"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.15
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ # Fix intltoolize broken file, see <https://bugzilla.gnome.org/show_bug.cgi?id=577133>
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i "${S}/po/Makefile.in.in" || die "sed failed"
+}
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-bundle"
+}