summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/glance_store')
-rw-r--r--dev-python/glance_store/ChangeLog10
-rw-r--r--dev-python/glance_store/glance_store-0.4.0.ebuild42
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-python/glance_store/ChangeLog b/dev-python/glance_store/ChangeLog
index 51378252bf21..b5ac5fcf2c79 100644
--- a/dev-python/glance_store/ChangeLog
+++ b/dev-python/glance_store/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/glance_store
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/glance_store/ChangeLog,v 1.1 2014/11/18 22:13:50 prometheanfire Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/glance_store/ChangeLog,v 1.2 2015/04/30 18:47:16 prometheanfire Exp $
+
+*glance_store-0.4.0 (30 Apr 2015)
+
+ 30 Apr 2015; Matthew Thode <prometheanfire@gentoo.org>
+ +glance_store-0.4.0.ebuild:
+ bumping for kilo
*glance_store-0.1.10 (18 Nov 2014)
diff --git a/dev-python/glance_store/glance_store-0.4.0.ebuild b/dev-python/glance_store/glance_store-0.4.0.ebuild
new file mode 100644
index 000000000000..f240c5abdd66
--- /dev/null
+++ b/dev-python/glance_store/glance_store-0.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/glance_store/glance_store-0.4.0.ebuild,v 1.1 2015/04/30 18:47:16 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A connection pool for python-ldap"
+HOMEPAGE="http://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/oslo-config-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-0.12[${PYTHON_USEDEP}]
+ dev-python/enum34[${PYTHON_USEDEP}]
+ >=dev-python/python-cinderclient-1.0.6[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.13.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/ordereddict/d' requirements.txt
+ distutils-r1_python_prepare_all
+}