summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/colander')
-rw-r--r--dev-python/colander/ChangeLog7
-rw-r--r--dev-python/colander/colander-0.9.7.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/colander/ChangeLog b/dev-python/colander/ChangeLog
index a9cfb3b5b34f..6c85f7929419 100644
--- a/dev-python/colander/ChangeLog
+++ b/dev-python/colander/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/colander
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/ChangeLog,v 1.3 2012/02/22 23:42:21 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/ChangeLog,v 1.4 2012/04/08 19:33:43 floppym Exp $
+
+*colander-0.9.7 (08 Apr 2012)
+
+ 08 Apr 2012; Mike Gilbert <floppym@gentoo.org> +colander-0.9.7.ebuild:
+ Version bump, #411049 by Ian Delaney.
*colander-0.9.6 (22 Feb 2012)
diff --git a/dev-python/colander/colander-0.9.7.ebuild b/dev-python/colander/colander-0.9.7.ebuild
new file mode 100644
index 000000000000..b0522bef38dd
--- /dev/null
+++ b/dev-python/colander/colander-0.9.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/colander/colander-0.9.7.ebuild,v 1.1 2012/04/08 19:33:43 floppym Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="2:2.6 3:3.2"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.0 3.1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="A simple schema-based serialization and deserialization library"
+HOMEPAGE="http://docs.pylonsproject.org/projects/colander/en/latest/ http://pypi.python.org/pypi/colander"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+# MIT license is used by included (modified) iso8601.py code.
+LICENSE="repoze MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Depend on an ebuild of translationstring with Python 3 support.
+RDEPEND=">=dev-python/translationstring-1.1"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+# Include COPYRIGHT.txt because the license seems to require it.
+DOCS="CHANGES.txt COPYRIGHT.txt README.txt"
+
+src_install() {
+ distutils_src_install
+
+ # The docs do not currently build for me and depend on a theme
+ # only available from git that contains hardcoded references
+ # to files on https://static.pylonsproject.org/ (so the docs
+ # would not actually work offline). Include the source, which
+ # is at least somewhat readable.
+
+ docinto docs
+ dodoc docs/*.rst
+}