summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cgkit')
-rw-r--r--dev-python/cgkit/ChangeLog6
-rw-r--r--dev-python/cgkit/cgkit-1.2.0.ebuild40
-rw-r--r--dev-python/cgkit/cgkit-2.0.0_alpha7.ebuild52
3 files changed, 5 insertions, 93 deletions
diff --git a/dev-python/cgkit/ChangeLog b/dev-python/cgkit/ChangeLog
index eb4337b11e4c..4e75aea2444b 100644
--- a/dev-python/cgkit/ChangeLog
+++ b/dev-python/cgkit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/cgkit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/ChangeLog,v 1.22 2008/05/22 20:46:25 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/ChangeLog,v 1.23 2008/05/22 21:17:39 mr_bones_ Exp $
+
+ 22 May 2008; Michael Sterrett <mr_bones_@gentoo.org> -cgkit-1.2.0.ebuild,
+ -cgkit-2.0.0_alpha7.ebuild:
+ punt old ebuilds
22 May 2008; Markus Meier <maekke@gentoo.org> cgkit-2.0.0_alpha8.ebuild:
x86 stable, bug #223237
diff --git a/dev-python/cgkit/cgkit-1.2.0.ebuild b/dev-python/cgkit/cgkit-1.2.0.ebuild
deleted file mode 100644
index 1dbe36dbd099..000000000000
--- a/dev-python/cgkit/cgkit-1.2.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/cgkit-1.2.0.ebuild,v 1.4 2007/03/28 20:18:37 opfer Exp $
-
-inherit distutils
-
-DESCRIPTION="Python library for creating 3D images"
-SRC_URI="mirror://sourceforge/${PN}/${P}.zip
- mirror://sourceforge/${PN}/${P}-doc.zip"
-HOMEPAGE="http://cgkit.sourceforge.net"
-RDEPEND="dev-lang/python
- dev-python/pyrex"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc"
-IUSE="doc"
-
-src_unpack() {
- unpack ${A}
- # this forces the file to be regenerated by the build system using
- # pyrex. Compilation with GCC 4 would fail otherwise, see
- # bug #152210
- rm "${S}/cgtypes.c"
-}
-src_install () {
- distutils_src_install
- if use doc; then
- cd ${WORKDIR}
- dohtml *.html
- cp -ar pics ${D}/usr/share/doc/${PF}/html/
- cd ${S}/examples
- for example in *; do
- dodir /usr/share/${P}/examples/${example}
- exeinto /usr/share/${P}/examples/${example}
- doexe ${example}/*.py
- done
- fi
-}
diff --git a/dev-python/cgkit/cgkit-2.0.0_alpha7.ebuild b/dev-python/cgkit/cgkit-2.0.0_alpha7.ebuild
deleted file mode 100644
index 1278af17a52c..000000000000
--- a/dev-python/cgkit/cgkit-2.0.0_alpha7.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cgkit/cgkit-2.0.0_alpha7.ebuild,v 1.4 2008/05/22 14:45:33 bicatali Exp $
-
-inherit distutils flag-o-matic
-
-MY_P=${P/_/}
-DESCRIPTION="Python library for creating 3D images"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-HOMEPAGE="http://cgkit.sourceforge.net"
-RDEPEND="dev-lang/python
- dev-python/pyrex
- dev-libs/boost
- dev-python/pyprotocols
- dev-python/pyopengl
- dev-python/pygame
- dev-python/imaging
- 3ds? ( media-libs/lib3ds )
- ogre? ( =dev-games/ogre-0.15.1 )"
-DEPEND="${RDEPEND}
- dev-util/scons"
-
-SLOT="0"
-LICENSE="LGPL-2.1 MPL-1.1 GPL-2"
-KEYWORDS="~ppc x86"
-IUSE="3ds ogre"
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e "s/fPIC/fPIC\",\"${CFLAGS// /\",\"}/" supportlib/SConstruct
- cp config_template.cfg config.cfg
- echo 'LIBS += ["GL", "GLU", "glut"]' >> config.cfg
- if use 3ds; then
- echo 'LIB3DS_AVAILABLE = True' >> config.cfg
- fi
- if use ogre; then
- echo 'OGRE_AVAILABLE = True' >> config.cfg
- echo 'INC_DIRS += ["/usr/include/OGRE"]' >> config.cfg
- echo 'MACROS += [("EXT_HASH", None),("GCC_3_1",None)]' >> config.cfg
- sed -i -e "s/#include <Math.h>//" wrappers/ogre/OgreCore.h
- fi
- sed -i -e "s:INC_DIRS = \[\]:INC_DIRS = \['/usr/include'\]:" "${S}"/setup.py
-}
-
-src_compile() {
- cd "${S}"/supportlib
- scons ${MAKEOPTS}
- cd "${S}"
- distutils_src_compile
-}