summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/IcePy')
-rw-r--r--dev-python/IcePy/ChangeLog7
-rw-r--r--dev-python/IcePy/IcePy-3.1.0.ebuild56
-rw-r--r--dev-python/IcePy/IcePy-3.1.1.ebuild55
-rw-r--r--dev-python/IcePy/files/digest-IcePy-3.1.03
-rw-r--r--dev-python/IcePy/files/digest-IcePy-3.1.13
-rw-r--r--dev-python/IcePy/files/icepy-3.1.0-makefile.patch66
-rw-r--r--dev-python/IcePy/files/icepy-3.1.1-makefile.patch74
7 files changed, 6 insertions, 258 deletions
diff --git a/dev-python/IcePy/ChangeLog b/dev-python/IcePy/ChangeLog
index 671ab79f89fd..14874d79c4d2 100644
--- a/dev-python/IcePy/ChangeLog
+++ b/dev-python/IcePy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/IcePy
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/IcePy/ChangeLog,v 1.4 2007/07/20 19:07:01 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/IcePy/ChangeLog,v 1.5 2007/07/24 12:20:12 caleb Exp $
+
+ 24 Jul 2007; Caleb Tennis <caleb@gentoo.org>
+ -files/icepy-3.1.0-makefile.patch, -files/icepy-3.1.1-makefile.patch,
+ -IcePy-3.1.0.ebuild, -IcePy-3.1.1.ebuild:
+ remove old versions
*IcePy-3.2.0 (20 Jul 2007)
diff --git a/dev-python/IcePy/IcePy-3.1.0.ebuild b/dev-python/IcePy/IcePy-3.1.0.ebuild
deleted file mode 100644
index fe87fac14fa5..000000000000
--- a/dev-python/IcePy/IcePy-3.1.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/IcePy/IcePy-3.1.0.ebuild,v 1.2 2006/10/30 13:35:25 caleb Exp $
-
-inherit eutils python
-
-DESCRIPTION="ICE middleware C++ bindings"
-HOMEPAGE="http://www.zeroc.com/index.html"
-SRC_URI="http://www.zeroc.com/download/Ice/3.1/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="test debug"
-
-DEPEND="=dev-cpp/Ice-3.1*"
-
-ICE_HOME=/usr
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch ${FILESDIR}/icepy-3.1.0-makefile.patch
-
- if use amd64; then
- sed -i -e "s:^#LP64:LP64:g" ${S}/config/Make.rules \
- || die "Failed to set lib64 directory"
- fi
-
- if ! use debug; then
- sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
- ${S}/config/Make.rules || die "Failed to remove debug"
- fi
-
- sed -i -e \
- "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
- ${S}/config/Make.rules.Linux || die "CXXFLAGS patching failed!"
-}
-
-src_compile() {
- cd ${S}
- export ICE_HOME=/usr
- ./configure
- make || die "Died during make"
-}
-
-src_install() {
- export ICE_HOME=/usr
- make DESTDIR="${D}" install || die "Install Failed!"
-}
-
-src_test() {
- export ICE_HOME=/usr
- make test || die "Test failed"
-}
diff --git a/dev-python/IcePy/IcePy-3.1.1.ebuild b/dev-python/IcePy/IcePy-3.1.1.ebuild
deleted file mode 100644
index 68bb6721acaf..000000000000
--- a/dev-python/IcePy/IcePy-3.1.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/IcePy/IcePy-3.1.1.ebuild,v 1.2 2006/10/30 13:35:25 caleb Exp $
-
-inherit eutils python
-
-DESCRIPTION="ICE middleware C++ bindings"
-HOMEPAGE="http://www.zeroc.com/index.html"
-SRC_URI="http://www.zeroc.com/download/Ice/3.1/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="test debug"
-
-DEPEND="=dev-cpp/Ice-3.1*"
-
-ICE_HOME=/usr
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch ${FILESDIR}/icepy-${PV}-makefile.patch
-
- if use amd64; then
- sed -i -e "s:^#LP64:LP64:g" ${S}/config/Make.rules \
- || die "Failed to set lib64 directory"
- fi
-
- if ! use debug; then
- sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
- ${S}/config/Make.rules || die "Failed to remove debug"
- fi
-
- sed -i -e \
- "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
- ${S}/config/Make.rules.Linux || die "CXXFLAGS patching failed!"
-}
-
-src_compile() {
- cd ${S}
- export ICE_HOME=/usr
- make || die "Died during make"
-}
-
-src_install() {
- export ICE_HOME=/usr
- make DESTDIR="${D}" install || die "Install Failed!"
-}
-
-src_test() {
- export ICE_HOME=/usr
- make test || die "Test failed"
-}
diff --git a/dev-python/IcePy/files/digest-IcePy-3.1.0 b/dev-python/IcePy/files/digest-IcePy-3.1.0
deleted file mode 100644
index 4a9e0036f668..000000000000
--- a/dev-python/IcePy/files/digest-IcePy-3.1.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 087162a14ade7f9c97e6e782fbf29471 IcePy-3.1.0.tar.gz 391534
-RMD160 d74170a1c002ac407084cdb05e7d7579c300e1e0 IcePy-3.1.0.tar.gz 391534
-SHA256 fe11e1250f6a315fb0ad8c67a533ecab4e9e0b920ee88a3880efd094470194fd IcePy-3.1.0.tar.gz 391534
diff --git a/dev-python/IcePy/files/digest-IcePy-3.1.1 b/dev-python/IcePy/files/digest-IcePy-3.1.1
deleted file mode 100644
index 7a14bdeb7b3a..000000000000
--- a/dev-python/IcePy/files/digest-IcePy-3.1.1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 96023adfb1449fd633d57e4dc1d5a876 IcePy-3.1.1.tar.gz 399743
-RMD160 d0bf996b20bacc563e60766047224e2f55c42b05 IcePy-3.1.1.tar.gz 399743
-SHA256 e0e104f4bfc19d97ed9ab11e34a7365055a6cb9a7f8aa0d95b60bd469285c20b IcePy-3.1.1.tar.gz 399743
diff --git a/dev-python/IcePy/files/icepy-3.1.0-makefile.patch b/dev-python/IcePy/files/icepy-3.1.0-makefile.patch
deleted file mode 100644
index 7f86129dfa1c..000000000000
--- a/dev-python/IcePy/files/icepy-3.1.0-makefile.patch
+++ /dev/null
@@ -1,66 +0,0 @@
---- config/Make.rules.orig 2006-09-11 07:47:26.000000000 -0400
-+++ config/Make.rules 2006-09-11 08:05:29.000000000 -0400
-@@ -16,13 +16,13 @@
- # if it does not exist.
- #
-
--prefix = /opt/IcePy-$(VERSION)
-+prefix = $(DESTDIR)/usr
-
- #
- # When creating an executable, shall we add install_libdir to the
- # runpath embedded in this executable?
- #
--ADD_LIBDIR_TO_RPATH ?= yes
-+#ADD_LIBDIR_TO_RPATH ?= yes
-
-
- #
-@@ -106,7 +106,7 @@
- ifeq ($(shell test -d $(top_srcdir)/slice && echo 0),0)
- slicedir = $(top_srcdir)/slice
- else
-- slicedir = $(ICE_HOME)/slice
-+ slicedir = $(prefix)/share/icepy-3.1.0/slice
- endif
-
- ifeq ($(LP64),yes)
-@@ -116,11 +116,11 @@
- #
- install_libdir = $(prefix)/python
- else
-- install_libdir = $(prefix)/python
-+ install_libdir = $(prefix)/lib/$(PYTHON_VERSION)/site-packages
- endif
-
--install_slicedir = $(prefix)/slice
--install_pythondir = $(prefix)/python
-+install_slicedir = $(prefix)/share/icepy-3.1.0/slice
-+install_pythondir = $(prefix)/lib/$(PYTHON_VERSION)
-
- INSTALL = cp -fp
- INSTALL_PROGRAM = ${INSTALL}
---- config/Make.rules.orig 2006-09-11 08:15:10.000000000 -0400
-+++ config/Make.rules 2006-09-11 08:15:18.000000000 -0400
-@@ -195,7 +195,7 @@
- endif
-
- ifeq ($(mkdir),)
-- mkdir = mkdir $(1) ; \
-+ mkdir = mkdir -p $(1) ; \
- chmod a+rx $(1)
- endif
-
---- Makefile.orig 2006-09-11 08:21:20.000000000 -0400
-+++ Makefile 2006-09-11 08:21:44.000000000 -0400
-@@ -69,8 +69,8 @@
- fi
-
- install::
-- $(call installdata,ICE_LICENSE,$(prefix))
-- $(call installdata,LICENSE,$(prefix))
-+ $(call installdata,ICE_LICENSE,$(install_slicedir))
-+ $(call installdata,LICENSE,$(install_slicedir))
-
- test::
- @python $(top_srcdir)/allTests.py
diff --git a/dev-python/IcePy/files/icepy-3.1.1-makefile.patch b/dev-python/IcePy/files/icepy-3.1.1-makefile.patch
deleted file mode 100644
index 350470860f8e..000000000000
--- a/dev-python/IcePy/files/icepy-3.1.1-makefile.patch
+++ /dev/null
@@ -1,74 +0,0 @@
---- config/Make.rules.orig 2006-10-16 09:46:19.000000000 -0400
-+++ config/Make.rules 2006-10-16 09:49:52.000000000 -0400
-@@ -16,13 +16,13 @@
- # if it does not exist.
- #
-
--prefix = /opt/IcePy-$(VERSION)
-+prefix = $(DESTDIR)/usr
-
- #
- # The "root directory" for runpath embedded in executables. Can be unset
- # to avoid adding a runpath to Ice executables.
- #
--embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-+#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-
- #
- # Define OPTIMIZE as yes if you want to build with optimization.
-@@ -127,7 +127,7 @@
- ifeq ($(shell test -d $(top_srcdir)/slice && echo 0),0)
- slicedir = $(top_srcdir)/slice
- else
-- slicedir = $(ICE_HOME)/slice
-+ slicedir = $(prefix)/share/icepy-$(VERSION)/slice
- endif
-
- ifeq ($(LP64),yes)
-@@ -135,9 +135,9 @@
- # TODO: Where should the shared library be installed if it is a 64 bit
- # build.
- #
-- install_libdir = $(prefix)/python
-+ install_libdir = $(prefix)/lib$(lp64suffix)
- else
-- install_libdir = $(prefix)/python
-+ install_libdir = $(prefix)/lib
- endif
-
- ifeq ($(LP64),yes)
-@@ -203,7 +203,7 @@
- endif
-
- ifeq ($(mkdir),)
-- mkdir = mkdir $(1) ; \
-+ mkdir = mkdir -p $(1) ; \
- chmod a+rx $(1)
- endif
-
---- Makefile.orig 2006-10-16 09:50:17.000000000 -0400
-+++ Makefile 2006-10-16 09:50:49.000000000 -0400
-@@ -69,8 +69,8 @@
- fi
-
- install::
-- $(call installdata,ICE_LICENSE,$(prefix))
-- $(call installdata,LICENSE,$(prefix))
-+ $(call installdata,ICE_LICENSE,$(install_slicedir))
-+ $(call installdata,LICENSE,$(install_slicedir))
-
- test::
- @python $(top_srcdir)/allTests.py
---- config/Make.rules.orig 2006-10-16 10:02:00.000000000 -0400
-+++ config/Make.rules 2006-10-16 10:04:04.000000000 -0400
-@@ -96,8 +96,8 @@
- SOVERSION = $(VERSION_MAJOR)$(VERSION_MINOR)
- libdir = $(top_srcdir)/python
-
--install_slicedir = $(prefix)/slice
--install_pythondir = $(prefix)/python
-+install_slicedir = $(prefix)/share/icepy-$(VERSION)/slice
-+install_pythondir = $(prefix)/lib/$(PYTHON_VERSION)/site-packages
-
- INSTALL = cp -fp
- INSTALL_PROGRAM = ${INSTALL}