summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-sqlite3/ChangeLog8
-rw-r--r--dev-ml/ocaml-sqlite3/ocaml-sqlite3-2.0.2.ebuild29
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-ml/ocaml-sqlite3/ChangeLog b/dev-ml/ocaml-sqlite3/ChangeLog
index cab79cda0ffc..68a1a71d3311 100644
--- a/dev-ml/ocaml-sqlite3/ChangeLog
+++ b/dev-ml/ocaml-sqlite3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocaml-sqlite3
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.26 2012/07/19 23:15:43 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.27 2012/08/02 12:50:03 aballier Exp $
+
+*ocaml-sqlite3-2.0.2 (02 Aug 2012)
+
+ 02 Aug 2012; Alexis Ballier <aballier@gentoo.org>
+ +ocaml-sqlite3-2.0.2.ebuild:
+ version bump
*ocaml-sqlite3-2.0.1 (19 Jul 2012)
diff --git a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-2.0.2.ebuild b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-2.0.2.ebuild
new file mode 100644
index 000000000000..f1eeb204d06d
--- /dev/null
+++ b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-2.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ocaml-sqlite3-2.0.2.ebuild,v 1.1 2012/08/02 12:50:03 aballier Exp $
+
+EAPI=4
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_PN="sqlite3-ocaml"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A package for ocaml that provides access to SQLite databases."
+HOMEPAGE="http://bitbucket.org/mmottl/sqlite3-ocaml"
+SRC_URI="http://bitbucket.org/mmottl/${MY_PN}/downloads/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-db/sqlite-3.3.3
+ >=dev-ml/findlib-1.3.2"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" "TODO.md" )