summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/ChangeLog7
-rw-r--r--dev-lang/mono/files/mono-1.2-glibc28.patch21
-rw-r--r--dev-lang/mono/mono-1.2.5.1-r1.ebuild5
3 files changed, 30 insertions, 3 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 314b3373d5b4..d2256973f2e1 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.153 2009/01/29 15:59:19 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.154 2009/02/12 01:23:02 dirtyepic Exp $
+
+ 12 Feb 2009; Ryan Hill <dirtyepic@gentoo.org>
+ +files/mono-1.2-glibc28.patch, mono-1.2.5.1-r1.ebuild:
+ Add patch to allow 1.2.5 to build against glibc-2.8. Required for
+ glibc-2.8 stabilization since mono-2 can't yet go stable.
29 Jan 2009; Peter Alfredsen <loki_val@gentoo.org> mono-2.2-r3.ebuild:
Add postinst message pointing to the additional packages that must be
diff --git a/dev-lang/mono/files/mono-1.2-glibc28.patch b/dev-lang/mono/files/mono-1.2-glibc28.patch
new file mode 100644
index 000000000000..2da5a3c3c72b
--- /dev/null
+++ b/dev-lang/mono/files/mono-1.2-glibc28.patch
@@ -0,0 +1,21 @@
+http://anonsvn.mono-project.com/viewvc?view=rev&revision=101444
+https://bugs.gentoo.org/225409
+backport for glibc-2.8 stablization
+https://bugs.gentoo.org/show_bug.cgi?id=247553
+--- trunk/mono/mono/io-layer/wapi_glob.c 2008/04/22 14:29:40 101443
++++ trunk/mono/mono/io-layer/wapi_glob.c 2008/04/22 14:44:10 101444
+@@ -299,11 +299,14 @@
+ }
+ pathv[pglob->gl_offs + pglob->gl_pathc] = NULL;
+
++#if 0
++ /* Broken on opensuse 11 */
+ if ((pglob->gl_flags & WAPI_GLOB_LIMIT) &&
+ newsize + *limitp >= ARG_MAX) {
+ errno = 0;
+ return(WAPI_GLOB_NOSPACE);
+ }
++#endif
+
+ return(copy == NULL ? WAPI_GLOB_NOSPACE : 0);
+ }
diff --git a/dev-lang/mono/mono-1.2.5.1-r1.ebuild b/dev-lang/mono/mono-1.2.5.1-r1.ebuild
index fac32845ede8..c68cf1db0f95 100644
--- a/dev-lang/mono/mono-1.2.5.1-r1.ebuild
+++ b/dev-lang/mono/mono-1.2.5.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.5.1-r1.ebuild,v 1.5 2008/03/02 19:34:27 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.5.1-r1.ebuild,v 1.6 2009/02/12 01:23:02 dirtyepic Exp $
inherit eutils flag-o-matic multilib autotools
@@ -52,6 +52,7 @@ src_unpack() {
|| die "sed failed"
epatch "${FILESDIR}/${PN}-1.2.4-pic.patch" || die "patch failed"
+ epatch "${FILESDIR}"/${PN}-1.2-glibc28.patch
# Remove dummy ltconfig and let libtool handle it
rm -f "${S}/libgc/ltconfig"