summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/commons-jelly')
-rw-r--r--dev-java/commons-jelly/commons-jelly-1.0.ebuild10
-rw-r--r--dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch3
2 files changed, 5 insertions, 8 deletions
diff --git a/dev-java/commons-jelly/commons-jelly-1.0.ebuild b/dev-java/commons-jelly/commons-jelly-1.0.ebuild
index 4e708e76033d..c106a9ce1809 100644
--- a/dev-java/commons-jelly/commons-jelly-1.0.ebuild
+++ b/dev-java/commons-jelly/commons-jelly-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-jelly/commons-jelly-1.0.ebuild,v 1.1 2005/12/24 02:24:06 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-jelly/commons-jelly-1.0.ebuild,v 1.2 2005/12/25 19:22:45 axxo Exp $
inherit java-pkg eutils
@@ -14,7 +14,8 @@ SLOT="1"
KEYWORDS="~x86"
IUSE="doc jikes junit source"
-COMMON_DEPS="~dev-java/servletapi-2.3
+RDEPEND=">=virtual/jre-1.4
+ ~dev-java/servletapi-2.3
=dev-java/commons-cli-1*
dev-java/commons-lang
dev-java/commons-discovery
@@ -26,6 +27,7 @@ COMMON_DEPS="~dev-java/servletapi-2.3
=dev-java/dom4j-1*
=dev-java/jaxen-1.1*
=dev-java/xerces-2*"
+
DEPEND=">=virtual/jdk-1.4
dev-java/ant-core
jikes? ( dev-java/jikes )
@@ -34,9 +36,7 @@ DEPEND=">=virtual/jdk-1.4
dev-java/ant-tasks
dev-java/commons-logging
)
- ${COMMON_DEPS}"
-RDEPEND=">=virtual/jre-1.4
- ${COMMON_DEPS}"
+ ${RDEPEND}"
S=${WORKDIR}/${MY_P}
diff --git a/dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch b/dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch
index cf12b4826e19..8fafca81ea79 100644
--- a/dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch
+++ b/dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch
@@ -1,4 +1,3 @@
-Only in commons-jelly-1.0-src-patched/: .build.xml.swp
diff -ru commons-jelly-1.0-src/build.xml commons-jelly-1.0-src-patched/build.xml
--- commons-jelly-1.0-src/build.xml 2005-06-16 10:39:44.000000000 -0400
+++ commons-jelly-1.0-src-patched/build.xml 2005-09-04 19:39:19.000000000 -0400
@@ -58,5 +57,3 @@ diff -ru commons-jelly-1.0-src/build.xml commons-jelly-1.0-src-patched/build.xml
-</project>
\ No newline at end of file
+</project>
-Only in commons-jelly-1.0-src-patched/: dist
-Only in commons-jelly-1.0-src-patched/: target