summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-kvm/ChangeLog6
-rw-r--r--app-emulation/qemu-kvm/files/qemu-kvm-1.0-fix-qemu-system-ppc.patch21
-rw-r--r--app-emulation/qemu-kvm/qemu-kvm-1.0.ebuild6
3 files changed, 31 insertions, 2 deletions
diff --git a/app-emulation/qemu-kvm/ChangeLog b/app-emulation/qemu-kvm/ChangeLog
index acd0fc37cb50..95ddf2a27b54 100644
--- a/app-emulation/qemu-kvm/ChangeLog
+++ b/app-emulation/qemu-kvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/qemu-kvm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/ChangeLog,v 1.85 2012/01/22 20:40:49 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/ChangeLog,v 1.86 2012/01/22 20:56:30 slyfox Exp $
+
+ 22 Jan 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/qemu-kvm-1.0-fix-qemu-system-ppc.patch, qemu-kvm-1.0.ebuild:
+ Fix build failure of qemu-system-ppc* targets.
22 Jan 2012; Sergei Trofimovich <slyfox@gentoo.org>
+files/qemu-kvm-1.0-fix-nonkvm-arches.patch,
diff --git a/app-emulation/qemu-kvm/files/qemu-kvm-1.0-fix-qemu-system-ppc.patch b/app-emulation/qemu-kvm/files/qemu-kvm-1.0-fix-qemu-system-ppc.patch
new file mode 100644
index 000000000000..bd611a305c9b
--- /dev/null
+++ b/app-emulation/qemu-kvm/files/qemu-kvm-1.0-fix-qemu-system-ppc.patch
@@ -0,0 +1,21 @@
+Fix the following build failure:
+ LINK ppc64-softmmu/qemu-system-ppc64
+../libhw64/i8259.o: In function `pic_read_irq':
+/tmp/portage/app-emulation/qemu-kvm-1.0/work/qemu-kvm-1.0/hw/i8259.c:240: undefined reference to `timer_acks'
+/tmp/portage/app-emulation/qemu-kvm-1.0/work/qemu-kvm-1.0/hw/i8259.c:240: undefined reference to `timer_acks'
+/tmp/portage/app-emulation/qemu-kvm-1.0/work/qemu-kvm-1.0/hw/i8259.c:241: undefined reference to `timer_ints_to_push'
+/tmp/portage/app-emulation/qemu-kvm-1.0/work/qemu-kvm-1.0/hw/i8259.c:242: undefined reference to `timer_ints_to_push'
+/tmp/portage/app-emulation/qemu-kvm-1.0/work/qemu-kvm-1.0/hw/i8259.c:242: undefined reference to `timer_ints_to_push'
+diff --git a/Makefile.target b/Makefile.target
+index 0b610ad..d8b1740 100644
+--- a/Makefile.target
++++ b/Makefile.target
+@@ -275,7 +275,7 @@ obj-ppc-y += virtex_ml507.o
+ obj-ppc-$(CONFIG_KVM) += kvm_ppc.o
+ obj-ppc-$(CONFIG_FDT) += device_tree.o
+ # PowerPC OpenPIC
+-obj-ppc-y += openpic.o
++obj-ppc-y += openpic.o i8254.o
+
+ # Xilinx PPC peripherals
+ obj-ppc-y += xilinx_intc.o
diff --git a/app-emulation/qemu-kvm/qemu-kvm-1.0.ebuild b/app-emulation/qemu-kvm/qemu-kvm-1.0.ebuild
index 7b43f4150025..9b436cf137af 100644
--- a/app-emulation/qemu-kvm/qemu-kvm-1.0.ebuild
+++ b/app-emulation/qemu-kvm/qemu-kvm-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-1.0.ebuild,v 1.4 2012/01/22 20:40:49 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-1.0.ebuild,v 1.5 2012/01/22 20:56:30 slyfox Exp $
#BACKPORTS=1
@@ -117,6 +117,9 @@ QA_WX_LOAD="${QA_PRESTRIPPED}
usr/bin/qemu-microblaze
usr/bin/qemu-mips
usr/bin/qemu-mipsel
+ usr/bin/qemu-ppc
+ usr/bin/qemu-ppc64
+ usr/bin/qemu-ppc64abi32
usr/bin/qemu-sh4
usr/bin/qemu-sh4eb
usr/bin/qemu-sparc
@@ -182,6 +185,7 @@ src_prepare() {
epatch "${FILESDIR}/qemu-0.11.0-mips64-user-fix.patch"
epatch "${FILESDIR}"/${PN}-1.0-fix-nonkvm-arches.patch
+ epatch "${FILESDIR}"/${PN}-1.0-fix-qemu-system-ppc.patch
[[ -n ${BACKPORTS} ]] && \
EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \