summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/gtk-splitter/gtk-splitter-2.2.ebuild21
1 files changed, 17 insertions, 4 deletions
diff --git a/app-arch/gtk-splitter/gtk-splitter-2.2.ebuild b/app-arch/gtk-splitter/gtk-splitter-2.2.ebuild
index 72944d4ba13d..40d5775fc65d 100644
--- a/app-arch/gtk-splitter/gtk-splitter-2.2.ebuild
+++ b/app-arch/gtk-splitter/gtk-splitter-2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/gtk-splitter/gtk-splitter-2.2.ebuild,v 1.7 2005/01/01 11:45:16 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gtk-splitter/gtk-splitter-2.2.ebuild,v 1.8 2005/03/18 00:39:04 vapier Exp $
DESCRIPTION="split/combine files !"
HOMEPAGE="http://gtk-splitter.sourceforge.net/"
@@ -8,12 +8,25 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc amd64"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="crypt"
-DEPEND=">=x11-libs/gtk+-2
+RDEPEND=">=x11-libs/gtk+-2
crypt? ( >=app-crypt/mhash-0.8 )"
-RDEPEND=">=dev-util/pkgconfig-0.12"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12"
+
+src_compile() {
+ econf || die
+ if ! use crypt ; then
+ # stupid configure script only autodetects
+ sed -i \
+ -e 's:-lmhash::' \
+ -e 's:-DHAVE_LIBMHASH=1::' \
+ src/Makefile
+ fi
+ emake || die "emake failed"
+}
src_install() {
make install DESTDIR="${D}" || die "make install failed"