summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/scons/ChangeLog7
-rw-r--r--dev-util/scons/files/digest-scons-0.96.92-r13
-rw-r--r--dev-util/scons/scons-0.96.92-r1.ebuild43
3 files changed, 52 insertions, 1 deletions
diff --git a/dev-util/scons/ChangeLog b/dev-util/scons/ChangeLog
index 5a50883bd153..ea2cff5367b3 100644
--- a/dev-util/scons/ChangeLog
+++ b/dev-util/scons/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/scons
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.35 2006/10/23 21:44:59 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.36 2006/11/03 14:03:33 twp Exp $
+
+*scons-0.96.92-r1 (03 Nov 2006)
+
+ 03 Nov 2006; <twp@gentoo.org> +scons-0.96.92-r1.ebuild:
+ Remove orphaned files from previous buggy builds. Bug # 153915. Thanks jakub!
*scons-0.96.92 (23 Oct 2006)
diff --git a/dev-util/scons/files/digest-scons-0.96.92-r1 b/dev-util/scons/files/digest-scons-0.96.92-r1
new file mode 100644
index 000000000000..11845d4053d1
--- /dev/null
+++ b/dev-util/scons/files/digest-scons-0.96.92-r1
@@ -0,0 +1,3 @@
+MD5 0b6b388cdd640b7f297f37a678c65d5c scons-0.96.92.tar.gz 372708
+RMD160 75aa04717da98eccabc42180f6eab9ee4b8bd904 scons-0.96.92.tar.gz 372708
+SHA256 c2ab6143174c0d3d2d6f2e5ae6bc77dd3a4843aba5e41d1265f54cdc2c17ebeb scons-0.96.92.tar.gz 372708
diff --git a/dev-util/scons/scons-0.96.92-r1.ebuild b/dev-util/scons/scons-0.96.92-r1.ebuild
new file mode 100644
index 000000000000..36b97a5039ed
--- /dev/null
+++ b/dev-util/scons/scons-0.96.92-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.96.92-r1.ebuild,v 1.1 2006/11/03 14:03:33 twp Exp $
+
+NEED_PYTHON="1.5.2"
+
+inherit python distutils multilib
+
+DESCRIPTION="Extensible Python-based build utility"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://www.scons.org"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DOCS="RELEASE.txt CHANGES.txt LICENSE.txt"
+
+src_install () {
+ distutils_src_install
+ doman scons.1 sconsign.1
+}
+
+pkg_postinst() {
+ python_mod_optimize ${ROOT}/usr/$(get_libdir)/${P}
+}
+
+pkg_prerm() {
+ # clean up stale junk left there by old faulty ebuilds
+ # see Bug 118022 and Bug 132448
+ if has_version "<dev-util/scons-0.96.92-r1" ; then
+ einfo "Cleaning up stale orphaned py[co] files..."
+ [[ -d "${ROOT}/usr/$(get_libdir)/scons/SCons" ]] \
+ && rm -rf "${ROOT}/usr/$(get_libdir)/scons/SCons"
+ einfo "Done."
+ fi
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${ROOT}/usr/$(get_libdir)/${P}
+}