summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/hdf5/ChangeLog10
-rw-r--r--dev-libs/hdf5/Manifest3
-rw-r--r--dev-libs/hdf5/files/digest-hdf5-1.4.51
-rw-r--r--dev-libs/hdf5/hdf5-1.4.5.ebuild54
4 files changed, 67 insertions, 1 deletions
diff --git a/dev-libs/hdf5/ChangeLog b/dev-libs/hdf5/ChangeLog
new file mode 100644
index 000000000000..a960acb1aa10
--- /dev/null
+++ b/dev-libs/hdf5/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-libs/hdf5
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hdf5/ChangeLog,v 1.1 2003/06/19 07:51:42 george Exp $
+
+*hdf5-1.4.5.ebuild (19 Jun 2003)
+
+ 19 Jun 2003; George Shapovalov <george@gentoo.org> hdf5-1.4.5.ebuild, Manifest, files/{digest-hdf5-1.4.5} :
+ initial release (#21071)
+ HDF5 is a general purpose library and file format for storing scientific data.
+ ebuild submitted by Castel?o <castelao@oceanologia.net> and Shaun Cloherty <s.cloherty@gsbme.unsw.edu.au>
diff --git a/dev-libs/hdf5/Manifest b/dev-libs/hdf5/Manifest
index 6d6dfea90d65..2b887282c525 100644
--- a/dev-libs/hdf5/Manifest
+++ b/dev-libs/hdf5/Manifest
@@ -1,2 +1,3 @@
-MD5 1eb0273a54feb9ec48a1865ec0bcd16a hdf5-1.4.5.ebuild 1365
+MD5 a6f9eafbc1b8c31b7f82e933bdf7fb67 hdf5-1.4.5.ebuild 1463
+MD5 d502b836cc5d97bd1925e704104accb5 ChangeLog 560
MD5 eb29b80216a0a85ed3dbe10cd7e9cb0f files/digest-hdf5-1.4.5 69
diff --git a/dev-libs/hdf5/files/digest-hdf5-1.4.5 b/dev-libs/hdf5/files/digest-hdf5-1.4.5
new file mode 100644
index 000000000000..89e8b7c68598
--- /dev/null
+++ b/dev-libs/hdf5/files/digest-hdf5-1.4.5
@@ -0,0 +1 @@
+MD5 657553ddfee1a7da0b5e2718203bcb44 hdf5-1.4.5-post2.tar.gz 3046682
diff --git a/dev-libs/hdf5/hdf5-1.4.5.ebuild b/dev-libs/hdf5/hdf5-1.4.5.ebuild
new file mode 100644
index 000000000000..2b32a7d23912
--- /dev/null
+++ b/dev-libs/hdf5/hdf5-1.4.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hdf5/hdf5-1.4.5.ebuild,v 1.1 2003/06/19 07:51:43 george Exp $
+
+DESCRIPTION="HDF5 is a general purpose library and file format for storing scientific data."
+SRC_URI="ftp://ftp.ncsa.uiuc.edu/HDF/HDF5/current/src/${P}-post2.tar.gz"
+HOMEPAGE="http://hdf.ncsa.uiuc.edu/HDF5/"
+
+LICENSE="NCSA-HDF"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE="static zlib"
+
+DEPEND="zlib? ( sys-libs/zlib )"
+PROVIDE="dev-libs/hdf5"
+
+# set the source directory
+S=${WORKDIR}/${P}-post2
+
+src_compile() {
+ local myconf
+
+ use static || myconf="--disable-static"
+ use zlib || myconf="${myconf} --disable-zlib"
+
+ # NOTE: the hdf5 configure script has its own interpretation of
+ # the ARCH environment variable which conflicts with that of
+ # ebuild/emerge. As a work around, we save the ARCH variable as
+ # EBUILD_ARCH and restore it when we are done.
+ EBUILD_ARCH=${ARCH}
+ unset ARCH
+
+ ./configure ${myconf} --enable-linux-lfs \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "configure failed"
+
+ # restore the ARCH environment variable
+ ARCH=${EBUILD_ARCH}
+
+ make || die "emake failed"
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die "make install failed"
+
+ dodoc README.txt COPYING MANIFEST
+ dohtml doc/html/*
+}