summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-25 19:59:46 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-25 19:59:46 +0000
commit7314ef1ad767698802b20c48f0d960d612227d15 (patch)
treeec95333e75e6181ebb116d7482a22f516a5ae433 /xfce-extra
parentVersion bump. (diff)
downloadgentoo-2-7314ef1ad767698802b20c48f0d960d612227d15.tar.gz
gentoo-2-7314ef1ad767698802b20c48f0d960d612227d15.tar.bz2
gentoo-2-7314ef1ad767698802b20c48f0d960d612227d15.zip
Version bump wrt #311335 by Michael Orlitzky.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-hdaps/ChangeLog8
-rw-r--r--xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.6.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-hdaps/ChangeLog b/xfce-extra/xfce4-hdaps/ChangeLog
index 45d1cf374a28..b78f7968c7f5 100644
--- a/xfce-extra/xfce4-hdaps/ChangeLog
+++ b/xfce-extra/xfce4-hdaps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-hdaps
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-hdaps/ChangeLog,v 1.1 2010/03/24 18:14:10 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-hdaps/ChangeLog,v 1.2 2010/03/25 19:59:46 ssuominen Exp $
+
+*xfce4-hdaps-0.0.6 (25 Mar 2010)
+
+ 25 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-hdaps-0.0.6.ebuild:
+ Version bump wrt #311335 by Michael Orlitzky.
*xfce4-hdaps-0.0.5 (24 Mar 2010)
diff --git a/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.6.ebuild b/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.6.ebuild
new file mode 100644
index 000000000000..72c0d54dd778
--- /dev/null
+++ b/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.6.ebuild,v 1.1 2010/03/25 19:59:46 ssuominen Exp $
+
+EAPI=2
+inherit linux-info xfconf
+
+DESCRIPTION="A plugin to indicate the status of the IBM Hard Drive Active Protection System"
+HOMEPAGE="http://michael.orlitzky.com/code/xfce4-hdaps.php"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+COMMON_DEPEND=">=x11-libs/gtk+-2.12:2
+ >=xfce-base/libxfce4ui-4.7
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/xfce4-panel-4.6"
+RDEPEND="${COMMON_DEPEND}
+ >=app-laptop/hdapsd-20081213
+ >=app-laptop/tp_smapi-0.39"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ XFCONF="--disable-option-checking
+ $(use_enable debug)"
+
+ linux-info_pkg_setup
+
+ if kernel_is lt 2 6 28; then
+ ewarn
+ ewarn "Unsupported kernel detected. Upgrade to 2.6.28 or above."
+ ewarn
+ fi
+}