summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-09-23 11:09:57 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-09-23 11:09:57 +0000
commit6ed67f8bed73fa5f6e4f0773b251ec35d2eea72a (patch)
treec064049f63565955e47c5aff20c79d8dc2f74537 /xfce-base
parentCleanups for #285951. (diff)
downloadgentoo-2-6ed67f8bed73fa5f6e4f0773b251ec35d2eea72a.tar.gz
gentoo-2-6ed67f8bed73fa5f6e4f0773b251ec35d2eea72a.tar.bz2
gentoo-2-6ed67f8bed73fa5f6e4f0773b251ec35d2eea72a.zip
Fix automagic xfce-base/thunar depend wrt #285738, thanks to Alexis Ballier for reporting. Revision bump in case the logic failed to avoid breakage.
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfdesktop/ChangeLog10
-rw-r--r--xfce-base/xfdesktop/files/xfdesktop-4.6.1-automagic.patch161
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.6.1-r1.ebuild85
3 files changed, 255 insertions, 1 deletions
diff --git a/xfce-base/xfdesktop/ChangeLog b/xfce-base/xfdesktop/ChangeLog
index b9d21d271e8c..3cb5dabe48a8 100644
--- a/xfce-base/xfdesktop/ChangeLog
+++ b/xfce-base/xfdesktop/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for xfce-base/xfdesktop
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/ChangeLog,v 1.148 2009/08/26 07:06:28 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/ChangeLog,v 1.149 2009/09/23 11:09:56 ssuominen Exp $
+
+*xfdesktop-4.6.1-r1 (23 Sep 2009)
+
+ 23 Sep 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +xfdesktop-4.6.1-r1.ebuild, +files/xfdesktop-4.6.1-automagic.patch:
+ Fix automagic xfce-base/thunar depend wrt #285738, thanks to Alexis
+ Ballier for reporting. Revision bump in case the logic failed to avoid
+ breakage.
26 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
xfdesktop-4.6.1.ebuild:
diff --git a/xfce-base/xfdesktop/files/xfdesktop-4.6.1-automagic.patch b/xfce-base/xfdesktop/files/xfdesktop-4.6.1-automagic.patch
new file mode 100644
index 000000000000..b70f1df3f9e7
--- /dev/null
+++ b/xfce-base/xfdesktop/files/xfdesktop-4.6.1-automagic.patch
@@ -0,0 +1,161 @@
+diff -ur xfdesktop-4.6.1.orig/modules/menu/desktop-menu.c xfdesktop-4.6.1/modules/menu/desktop-menu.c
+--- xfdesktop-4.6.1.orig/modules/menu/desktop-menu.c 2009-02-26 00:32:50.000000000 +0200
++++ xfdesktop-4.6.1/modules/menu/desktop-menu.c 2009-09-23 14:10:16.000000000 +0300
+@@ -63,7 +63,7 @@
+ #include <libxfcegui4/libxfcegui4.h>
+ #include <libxfce4menu/libxfce4menu.h>
+
+-#ifdef HAVE_THUNAR_VFS
++#ifdef ENABLE_FILE_ICONS
+ #include <thunar-vfs/thunar-vfs.h>
+ #endif
+
+@@ -82,7 +82,7 @@
+
+ gint idle_id; /* source id for idled generation */
+
+-#ifdef HAVE_THUNAR_VFS
++#ifdef ENABLE_FILE_ICONS
+ GList *monitors;
+ #endif
+ } XfceDesktopMenu;
+@@ -134,7 +134,7 @@
+ desktop_menu->idle_id = g_idle_add(_generate_menu_idled, desktop_menu);
+ }
+
+-#ifdef HAVE_THUNAR_VFS
++#ifdef ENABLE_FILE_ICONS
+
+ static void
+ desktop_menu_something_changed(ThunarVfsMonitor *monitor,
+@@ -443,7 +443,7 @@
+ xfce_desktop_menu_new_impl(const gchar *menu_file,
+ gboolean deferred)
+ {
+-#ifdef HAVE_THUNAR_VFS
++#ifdef ENABLE_FILE_ICONS
+ static XfceMenuMonitorVTable monitor_vtable = {
+ NULL, /*desktop_menu_xfce_menu_monitor_file,*/
+ desktop_menu_xfce_menu_monitor_directory,
+@@ -460,7 +460,7 @@
+ else
+ desktop_menu->filename = xfce_desktop_get_menufile();
+
+-#ifdef HAVE_THUNAR_VFS
++#ifdef ENABLE_FILE_ICONS
+ thunar_vfs_init();
+ xfce_menu_monitor_set_vtable(&monitor_vtable, desktop_menu);
+ #endif
+@@ -469,7 +469,7 @@
+ desktop_menu->idle_id = g_idle_add(_generate_menu_idled, desktop_menu);
+ else {
+ if(!_generate_menu(desktop_menu)) {
+-#ifdef HAVE_THUNAR_VFS
++#ifdef ENABLE_FILE_ICONS
+ xfce_menu_monitor_set_vtable(NULL, NULL);
+ #endif
+ g_free(desktop_menu);
+@@ -595,7 +595,7 @@
+ g_return_if_fail(desktop_menu != NULL);
+ TRACE("dummy");
+
+-#ifdef HAVE_THUNAR_VFS
++#ifdef ENABLE_FILE_ICONS
+ xfce_menu_monitor_set_vtable(NULL, NULL);
+ #endif
+
+diff -ur xfdesktop-4.6.1.orig/modules/menu/Makefile.am xfdesktop-4.6.1/modules/menu/Makefile.am
+--- xfdesktop-4.6.1.orig/modules/menu/Makefile.am 2009-01-13 00:03:21.000000000 +0200
++++ xfdesktop-4.6.1/modules/menu/Makefile.am 2009-09-23 14:04:57.000000000 +0300
+@@ -15,11 +15,15 @@
+ $(LIBXFCE4MENU_CFLAGS) \
+ $(LIBX11_CFLAGS) \
+ $(LIBXFCEGUI4_CFLAGS) \
+- $(THUNAR_VFS_CFLAGS) \
+ -DSYSCONFDIR=\"$(sysconfdir)\" \
+ -DDATADIR=\"$(datadir)\" \
+ -DBINDIR=\"$(bindir)\"
+
++if ENABLE_FILE_ICONS
++xfce4_desktop_menu_la_CFLAGS += \
++ $(THUNAR_VFS_CFLAGS)
++endif
++
+ xfce4_desktop_menu_la_DEPENDENCIES = \
+ $(top_builddir)/common/libxfdesktop-menu-utils.la
+
+@@ -40,5 +44,9 @@
+ $(LIBXFCE4MENU_LIBS) \
+ $(LIBX11_LDFLAGS) \
+ $(LIBX11_LIBS) \
+- $(LIBXFCEGUI4_LIBS) \
++ $(LIBXFCEGUI4_LIBS)
++
++if ENABLE_FILE_ICONS
++xfce4_desktop_menu_la_LIBADD += \
+ $(THUNAR_VFS_LIBS)
++endif
+diff -ur xfdesktop-4.6.1.orig/panel-plugin/desktop-menu-plugin.c xfdesktop-4.6.1/panel-plugin/desktop-menu-plugin.c
+--- xfdesktop-4.6.1.orig/panel-plugin/desktop-menu-plugin.c 2009-02-26 00:33:00.000000000 +0200
++++ xfdesktop-4.6.1/panel-plugin/desktop-menu-plugin.c 2009-09-23 14:09:30.000000000 +0300
+@@ -53,7 +53,7 @@
+ #include <libxfce4panel/xfce-panel-plugin.h>
+ #include <libxfce4panel/xfce-panel-convenience.h>
+
+-#ifdef HAVE_THUNAR_VFS
++#ifdef ENABLE_FILE_ICONS
+ #include <thunar-vfs/thunar-vfs.h>
+ #endif
+
+@@ -896,7 +896,7 @@
+ desktop_menu_plugin_preinit(int argc,
+ char **argv)
+ {
+-#ifdef HAVE_THUNAR_VFS
++#ifdef ENABLE_FILE_ICONS
+ g_thread_init(NULL);
+ #endif
+ return TRUE;
+@@ -1018,7 +1018,7 @@
+
+ xfce_textdomain(GETTEXT_PACKAGE, LOCALEDIR, "UTF-8");
+
+-#ifdef HAVE_THUNAR_VFS
++#ifdef ENABLE_FILE_ICONS
+ thunar_vfs_init();
+ #endif
+
+diff -ur xfdesktop-4.6.1.orig/panel-plugin/Makefile.am xfdesktop-4.6.1/panel-plugin/Makefile.am
+--- xfdesktop-4.6.1.orig/panel-plugin/Makefile.am 2009-01-13 00:03:12.000000000 +0200
++++ xfdesktop-4.6.1/panel-plugin/Makefile.am 2009-09-23 14:04:38.000000000 +0300
+@@ -9,11 +9,15 @@
+ $(LIBX11_CFLAGS) \
+ $(LIBXFCEGUI4_CFLAGS) \
+ $(LIBXFCE4PANEL_CFLAGS) \
+- $(THUNAR_VFS_CFLAGS) \
+ -DDATADIR=\"$(datadir)\" \
+ -DLOCALEDIR=\"$(localedir)\" \
+ -DBINDIR=\"$(bindir)\"
+
++if ENABLE_FILE_ICONS
++xfce4_menu_plugin_CFLAGS += \
++ $(THUNAR_VFS_CFLAGS)
++endif
++
+ xfce4_menu_plugin_DEPENDENCIES = \
+ $(top_builddir)/common/libxfdesktop-menu.la \
+ $(top_builddir)/common/libxfdesktop.la
+@@ -23,8 +27,12 @@
+ $(top_builddir)/common/libxfdesktop.la \
+ $(LIBX11_LIBS) \
+ $(LIBXFCEGUI4_LIBS) \
+- $(LIBXFCE4PANEL_LIBS) \
++ $(LIBXFCE4PANEL_LIBS)
++
++if ENABLE_FILE_ICONS
++xfce4_menu_plugin_LDADD += \
+ $(THUNAR_VFS_LIBS)
++endif
+
+ if HAVE_CYGWIN
+ xfce4_menu_plugin_LDFLAGS = \
diff --git a/xfce-base/xfdesktop/xfdesktop-4.6.1-r1.ebuild b/xfce-base/xfdesktop/xfdesktop-4.6.1-r1.ebuild
new file mode 100644
index 000000000000..ed92dde954ac
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.6.1-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/xfdesktop-4.6.1-r1.ebuild,v 1.1 2009/09/23 11:09:56 ssuominen Exp $
+
+EAPI=2
+EAUTORECONF=yes
+inherit xfconf
+
+DESCRIPTION="Desktop manager for Xfce4"
+HOMEPAGE="http://www.xfce.org/projects/xfdesktop"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.6/${P}.tar.bz2
+ branding? ( http://www.gentoo.org/images/backgrounds/gentoo-minimal-1280x1024.jpg )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+branding debug doc +menu-plugin thunar"
+
+LINGUAS="be ca cs da de el es et eu fi fr he hu it ja ko nb_NO nl pa pl pt_BR ro ru sk sv tr uk vi zh_CN zh_TW"
+
+for X in ${LINGUAS}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND="gnome-base/libglade
+ x11-libs/libX11
+ x11-libs/libSM
+ >=x11-libs/libwnck-2.12
+ >=dev-libs/glib-2.10:2
+ >=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfcegui4-4.6
+ >=xfce-base/libxfce4menu-4.6
+ >=xfce-base/xfconf-4.6
+ branding? ( >=x11-libs/gtk+-2.10:2[jpeg] )
+ thunar? ( >=xfce-base/thunar-1
+ >=xfce-base/exo-0.3.100
+ dev-libs/dbus-glib )
+ menu-plugin? ( >=xfce-base/xfce4-panel-4.6 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ dev-util/pkgconfig
+ doc? ( dev-libs/libxslt )"
+
+pkg_setup() {
+ XFCE_LOCALIZED_CONFIGS="/etc/xdg/xfce4/desktop/menu.xml
+ /etc/xdg/xfce4/desktop/xfce-registered-categories.xml"
+ XFCONF="--disable-dependency-tracking
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable thunar exo)
+ $(use_enable menu-plugin panel-plugin)
+ $(use_enable doc xsltproc)
+ $(use_enable debug)"
+ DOCS="AUTHORS ChangeLog NEWS TODO README"
+ PATCHES=( "${FILESDIR}/${P}-automagic.patch" )
+}
+
+src_prepare() {
+ if use branding; then
+ sed -i -e "s:xfce-stripes.png:gentoo-minimal-1280x1024.jpg:" \
+ common/xfdesktop-common.h || die "sed failed"
+ fi
+ xfconf_src_prepare
+}
+
+src_install() {
+ xfconf_src_install
+
+ if use branding; then
+ insinto /usr/share/xfce4/backdrops
+ doins "${DISTDIR}"/gentoo-minimal-1280x1024.jpg || die "doins failed"
+ fi
+
+ local config lang
+ for config in ${XFCE_LOCALIZED_CONFIGS}; do
+ for lang in ${LINGUAS}; do
+ local localized_config="${D}/${config}.${lang}"
+ if [[ -f ${localized_config} ]]; then
+ use "linguas_${lang}" || rm ${localized_config}
+ fi
+ done
+ done
+}