summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-12-19 13:42:31 +0000
committerPeter Volkov <pva@gentoo.org>2009-12-19 13:42:31 +0000
commit73801151750a0d8579c216466c62f63ea0f81458 (patch)
treecca037f42172858a33640d8c16656658473fa36f /x11-plugins/pidgin-encryption
parentVersion bump wrt #297515, thanks to Azamat H. Hackimov for reporting. (diff)
downloadgentoo-2-73801151750a0d8579c216466c62f63ea0f81458.tar.gz
gentoo-2-73801151750a0d8579c216466c62f63ea0f81458.tar.bz2
gentoo-2-73801151750a0d8579c216466c62f63ea0f81458.zip
Added patch from debian to fix crash, hopefully fixes bug #292321, thank Phil Stracchino for good backtrace.
(Portage version: 2.1.7.15/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/pidgin-encryption')
-rw-r--r--x11-plugins/pidgin-encryption/ChangeLog10
-rw-r--r--x11-plugins/pidgin-encryption/files/pidgin-encryption-3.0-crash.patch14
-rw-r--r--x11-plugins/pidgin-encryption/pidgin-encryption-3.0-r1.ebuild38
3 files changed, 61 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-encryption/ChangeLog b/x11-plugins/pidgin-encryption/ChangeLog
index 671a8b8bb0e1..7c90a891bf0f 100644
--- a/x11-plugins/pidgin-encryption/ChangeLog
+++ b/x11-plugins/pidgin-encryption/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-plugins/pidgin-encryption
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-encryption/ChangeLog,v 1.7 2009/02/05 05:11:25 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-encryption/ChangeLog,v 1.8 2009/12/19 13:42:30 pva Exp $
+
+*pidgin-encryption-3.0-r1 (19 Dec 2009)
+
+ 19 Dec 2009; Peter Volkov <pva@gentoo.org>
+ +pidgin-encryption-3.0-r1.ebuild,
+ +files/pidgin-encryption-3.0-crash.patch:
+ Added patch from debian to fix crash, hopefully fixes bug #292321, thank
+ Phil Stracchino for good backtrace.
05 Feb 2009; Jeremy Olexa <darkside@gentoo.org>
pidgin-encryption-3.0.ebuild:
diff --git a/x11-plugins/pidgin-encryption/files/pidgin-encryption-3.0-crash.patch b/x11-plugins/pidgin-encryption/files/pidgin-encryption-3.0-crash.patch
new file mode 100644
index 000000000000..92c852736512
--- /dev/null
+++ b/x11-plugins/pidgin-encryption/files/pidgin-encryption-3.0-crash.patch
@@ -0,0 +1,14 @@
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=525501
+https://bugs.gentoo.org/show_bug.cgi?id=292321
+
+--- pidgin-encryption-3.0.orig/state_ui.c 2007-05-07 02:15:27.000000000 +0200
++++ pidgin-encryption-3.0.new/state_ui.c 2009-04-26 17:08:02.000000000 +0200
+@@ -268,6 +268,8 @@
+ static GtkIMHtmlSmiley * create_smiley_if_absent(GtkIMHtml *imhtml) {
+ GtkIMHtmlSmiley * smiley;
+ const char* category = gtk_imhtml_get_protocol_name(imhtml);
++
++ if (!category) return NULL;
+
+ /* make sure that the category we're about to use to add (based on the protocol name) */
+ /* already exists. If it doesn't, just use the default category so it isn't created. */
diff --git a/x11-plugins/pidgin-encryption/pidgin-encryption-3.0-r1.ebuild b/x11-plugins/pidgin-encryption/pidgin-encryption-3.0-r1.ebuild
new file mode 100644
index 000000000000..b3133cb68ed0
--- /dev/null
+++ b/x11-plugins/pidgin-encryption/pidgin-encryption-3.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-encryption/pidgin-encryption-3.0-r1.ebuild,v 1.1 2009/12/19 13:42:30 pva Exp $
+
+EAPI="2"
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Pidgin IM Encryption PlugIn"
+HOMEPAGE="http://pidgin-encrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gaim-encryption/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="net-im/pidgin
+ >=x11-libs/gtk+-2
+ >=dev-libs/nss-3.11"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-crash.patch"
+}
+
+src_configure() {
+ strip-flags
+ replace-flags -O? -O2
+ econf $(use_enable nls)
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "Install failed"
+ dodoc CHANGELOG INSTALL NOTES README TODO VERSION WISHLIST
+}