summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-11-25 00:27:00 +0000
committerNaohiro Aota <naota@gentoo.org>2011-11-25 00:27:00 +0000
commit1e33ac70e1273b5beb7e98d286f7788945b1dc0a (patch)
tree217a4263cebf7770bc0e0fbe9e1f26f820074e2a /x11-libs
parentold (diff)
downloadgentoo-2-1e33ac70e1273b5beb7e98d286f7788945b1dc0a.tar.gz
gentoo-2-1e33ac70e1273b5beb7e98d286f7788945b1dc0a.tar.bz2
gentoo-2-1e33ac70e1273b5beb7e98d286f7788945b1dc0a.zip
Add patch to replace non-POSIX test. Bug #387087
(Portage version: 2.2.0_alpha75/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pixman/ChangeLog6
-rw-r--r--x11-libs/pixman/files/pixman-0.24.0-posix-test.patch13
-rw-r--r--x11-libs/pixman/pixman-0.24.0.ebuild5
3 files changed, 22 insertions, 2 deletions
diff --git a/x11-libs/pixman/ChangeLog b/x11-libs/pixman/ChangeLog
index 4e01a747de19..9b04cfc852bc 100644
--- a/x11-libs/pixman/ChangeLog
+++ b/x11-libs/pixman/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/pixman
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/ChangeLog,v 1.115 2011/11/07 13:42:46 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/ChangeLog,v 1.116 2011/11/25 00:27:00 naota Exp $
+
+ 25 Nov 2011; Naohiro Aota <naota@gentoo.org> pixman-0.24.0.ebuild,
+ +files/pixman-0.24.0-posix-test.patch:
+ Add patch to replace non-POSIX test. Bug #387087
*pixman-0.24.0 (07 Nov 2011)
diff --git a/x11-libs/pixman/files/pixman-0.24.0-posix-test.patch b/x11-libs/pixman/files/pixman-0.24.0-posix-test.patch
new file mode 100644
index 000000000000..a96ed95463e7
--- /dev/null
+++ b/x11-libs/pixman/files/pixman-0.24.0-posix-test.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 0c23831..b851e96 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -150,7 +150,7 @@ AC_CHECK_DECL([__amd64], [AMD64_ABI="yes"], [AMD64_ABI="no"])
+ # if we're using Sun Studio and neither the user nor a config.site
+ # has set CFLAGS.
+ if test $SUNCC = yes && \
+- test "$test_CFLAGS" == "" && \
++ test "x$test_CFLAGS" = "x" && \
+ test "$CFLAGS" = "-g"
+ then
+ CFLAGS="-O -g"
diff --git a/x11-libs/pixman/pixman-0.24.0.ebuild b/x11-libs/pixman/pixman-0.24.0.ebuild
index 7f161966582f..3bd4229d130f 100644
--- a/x11-libs/pixman/pixman-0.24.0.ebuild
+++ b/x11-libs/pixman/pixman-0.24.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/pixman-0.24.0.ebuild,v 1.1 2011/11/07 13:42:46 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pixman/pixman-0.24.0.ebuild,v 1.2 2011/11/25 00:27:00 naota Exp $
EAPI=4
inherit xorg-2 toolchain-funcs versionator
@@ -11,6 +11,9 @@ DESCRIPTION="Low-level pixel manipulation routines"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
IUSE="altivec iwmmxt mmx neon sse2"
+PATCHES=( "${FILESDIR}"/${P}-posix-test.patch )
+XORG_EAUTORECONF="yes"
+
pkg_setup() {
xorg-2_pkg_setup