summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2005-07-12 18:39:03 +0000
committerRob Cakebread <pythonhead@gentoo.org>2005-07-12 18:39:03 +0000
commit0f079679086f30cb375ec2f9f2c1bafa353e267d (patch)
tree65a0f0d8bf7c381c4a876ce3a13579fffe315db6 /x11-libs/wxGTK/wxGTK-2.6.1.ebuild
parentDeps/Style fixs (diff)
downloadgentoo-2-0f079679086f30cb375ec2f9f2c1bafa353e267d.tar.gz
gentoo-2-0f079679086f30cb375ec2f9f2c1bafa353e267d.tar.bz2
gentoo-2-0f079679086f30cb375ec2f9f2c1bafa353e267d.zip
Version bump.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-libs/wxGTK/wxGTK-2.6.1.ebuild')
-rw-r--r--x11-libs/wxGTK/wxGTK-2.6.1.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/x11-libs/wxGTK/wxGTK-2.6.1.ebuild b/x11-libs/wxGTK/wxGTK-2.6.1.ebuild
new file mode 100644
index 000000000000..c4856af42db6
--- /dev/null
+++ b/x11-libs/wxGTK/wxGTK-2.6.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.6.1.ebuild,v 1.1 2005/07/12 18:39:03 pythonhead Exp $
+
+inherit wxlib gnuconfig
+
+DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit and
+wxbase non-gui library"
+
+SLOT="2.6"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~amd64 ~ia64 ~hppa ~ppc64"
+IUSE="gnome gtk2 joystick odbc opengl sdl wxgtk1"
+
+RDEPEND="${RDEPEND}
+ opengl? ( virtual/opengl )
+ gtk2? ( >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0 )
+ wxgtk1? ( =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2* )
+ wxgtk1? ( gtk2? (media-libs/libpng
+ media-libs/jpeg
+ media-libs/tiff))
+ odbc? ( dev-db/unixODBC )
+ !mips? ( !arm? ( !hppa? ( !ia64? ( !ppc64? ( !alpha? ( !sparc? ( sdl? ( media-libs/sdl-sound ))))))))"
+
+DEPEND="${RDEPEND}
+ ${DEPEND}
+ gtk2? ( dev-util/pkgconfig )"
+S=${WORKDIR}/wxWidgets-${PV}
+
+pkg_setup() {
+ einfo "To install only wxbase (non-gui libs) use -gtk2 -wxgtk1"
+ if use unicode; then
+ ! use gtk2 && die "You must put gtk2 in your USE if you need unicode support"
+ fi
+}
+
+src_compile() {
+ gnuconfig_update
+ if use wxgtk1 || use gtk2; then
+ myconf="${myconf}
+ --with-png
+ --with-jpeg
+ --with-tiff
+ $(use_enable opengl)
+ $(use_with opengl)
+ $(use_with gnome gnomeprint)
+ $(use_with sdl)
+ $(use_enable joystick)"
+ fi
+
+ use wxgtk1 && \
+ configure_build gtk1 "" "${myconf} --with-gtk=1"
+
+ use gtk2 && \
+ configure_build gtk2 unicode "${myconf} --with-gtk=2"
+
+ ! use gtk2 && ! use wxgtk1 && \
+ configure_build base unicode "--disable-gui"
+}
+
+src_install() {
+ use wxgtk1 && install_build gtk1
+ use gtk2 && install_build gtk2
+ ! use gtk2 && ! use wxgtk1 && install_build base
+
+ wxlib_src_install
+}
+
+pkg_postinst() {
+ einfo "dev-libs/wxbase has been removed from portage and can be"
+ einfo "installed with wxGTK by specifying the USE flags"
+ einfo "-gtk2 and -wxgtk1"
+}